Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
zathras
Level 8

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Yep, mine's bee mostly effed up since 10/28. Netflix is the only channel that doesn't have issues or is slow. I think they seriously screwed up the network stack. 

Disney+ and Hulu fail to load with couldn't find network. Amazon loads, reports a network error in multiple languages and won't play anything. Criterion channel and HBOMax load, but fail to play. Criterion throws an error, HBOMax just fails back to the last screen before play. It's a total cluster. 

masterv855
Level 8

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

I have a Westinghouse Roku Tv and have been having literally the same issues you both described since yesterday. Tried all troubleshooting steps, but nothing has been able to resolve it. Must be an issue with the update or the service. Glad to know I’m not the only one having this issue, but I hope Roku resolves it soon.

St3ph3n
Level 7

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

I'm having the same problem on my 4660X since it got updated to 10.5.0 midweek.

Netflix works fine.

Hulu won't load - when you start the app, you get a hulu logo screen for a while, then eventually a network error.

Youtube loads really slowly, and may or may not play videos.

HBO Max loads really slowly, like it's waiting for something to time out. Once it loads up and you try to play a video, it silently fails after about 30 seconds of a blank screen and goes back to the main HBO Max menu.

AppleTV loads slowly, and is slow to render page to page. Once you try to play a video it sits at a black loading screen for a while and then says 'video not available'.

Amazon Prime Video fails to load, stating 'internet connectivity problem' in multiple languages.

My internet connection is plenty fast (350Mbps) and working fine with other devices. All of these services worked fine until 10.5.0 showed up. Roku is connected via wired ethernet. Doing a 'check connection' shows it to be connected and getting 83 Mbps. I've tried resetting the network, checking for updates, and rebooting the roku several times to no avail. This is ludicrously broken.

Tags (2)
kathi
Level 8

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

Another victim with a 4660 RW, thought I was nuts since, like others here, Netflix worked fine, other Roku devices worked fine so obviously there is no problem with internet service.  I hardily agree with Blue85wish that you should be able to go back to previous version until a fix is found.  I gave that suggestion when Roku asked me to take a survey.  Am leaving mine plugged in and hoping if enough complaints come in they will get a fix out soon. 

RyanPm40
Level 9

Re: anybody else have issues with Model 4660X- roku ultra after update 10.5.0?

Jump to solution

YES. It completely broke my Roku! YouTube takes forever to open, then all thumbnails are grey for a solid minute. HBO Max is very slow and refuses to play anything - an episode tries to load for 30 seconds before kicking me out to the homescreen of HBO. Hulu just doesn't open at all. It shows the logo for 30 seconds and gives a network error. Roku needs to fix this asap or let us downgrade

RyanPm40
Level 9

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

Exact same issue on my 4660X Roku Ultra! It just updated last night to 10.5.0 and now everything is broken! This isn't the first time Roku has broken things with an update, and honestly, I am done. Their quality control is an absolute joke. Going to get an Apple TV 4K.

jamowa52
Level 9

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

My Ultra 4660X updated to 10.5 build 4198-46 on 11.04.21. No joy.  All my channels load very slowly and often stutter when loading. I have the same problem w/ Amazon loading then presenting multi-language error messages.  Hulu was not loading at all. Likewise the Ad banner on the main channel screen is blank. 

So far we have: updated Roku, reset Roku, reset Wifi connection, updated all channels......and the problem continues. When we attempt to load Hulu an error message presents "Network error. Check network connection. If error persists, visit www/hulu.com/help."

As an experiment, we uninstalled Hulu, and reinstalled Hulu from the Roku website because Ultra could not locate Hulu via the Channel Store search. In fact, the Channel Store loads very slowly, if at all. Since the Hulu channel still won't load (Network error) we cannot activate it. Sigh.

All other older Roku models work flawlessly. When can we expect a fix?

RyanPm40
Level 9

Re: Roku Ultra Firmware 10.5.0 Needs Patch ASAP

Jump to solution

Yeah 10.5.0 completely broke my 4660X Ultra. HBO Max is very slow, and refuses to play anything before kicking you back to it's landing page. Hulu doesn't open at all and gives a network error. YouTube opens very slowly, and then has greyed out thumbnails for a minute, etc. 

I bought a Chromecast with Google TV tonight (the one with a remote) and I'm absolutely loving it so far. A much better user interface at a great price. 

DawgDawg
Level 8

Re: anybody else have issues with Model 4660X- roku ultra after update 10.5.0?

Jump to solution

Same here. Hulu and Prime both fail. Netflix and Apple still OK. Gives me an excuse to buy new LG OLED and ditch the Ultra.

RokuMary-F
Roku Employee
Roku Employee

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

Hi everyone,

Thanks for posting in the Roku Community!

Our engineering team would like to take a look to see if we can help here.

Please provide us with the following information:
-Roku device model
-serial number
-device ID
-software OS/version (these can all be found in Settings > System > About)
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel (this can be found by selecting the channel on the Home screen and pressing the * button)
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times)
-steps to reproduce the issue you are seeing
With more information, we will be able to assist you further.

Regards,
Mary