Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JROtis
Level 7

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

Hi Danny, we’re experiencing the same issues on our Roku with the update that several others are. I’ve done the manual check and it says: software version:10.5.0 Build:4201. Can you please help us with this situation? Thanks, Jerry 

srandyt
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

I could not post when I first signed up, either. After I responded to this post, I got enough status to be able to post. Keep checking.

Hendra
Level 7

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

Same experience! We have 3 Roku TVs, and now are unable to access YouTubeLive (and potentially others). We have tried all the suggestions, including factory reset. I have been reading about this issue for months. With so many users experiencing the same issue with your update, what will Roku be doing to resolve the problem? Is the expectation we all go out to buy streaming devices to attach to the TV? We purchased our Roku TVs to have the built-in streaming capability.

It is not a memory/space issue, as after the factory reset we have fewer apps on the TV than when it all worked fine 2 days ago. If no solution provided via update, will Roku supply it's Roku TV owners with an external streaming device? Or will you expect us all to go spend more money on such devices since our TVs now will not work without one?

Lane03
Level 10

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

Not as severe as what others were reporting, but I have multiple RokuTVs (TCL 55S405) and all began experiencing brief split second audio drop outs when streaming from Disney+. Rolling back firmware from 10.5 to 10 fixed the audio issues.

RosemaryE
Level 7

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

I have a TCL Roku TV, model 55S421-CA and same issue...can't watch BritBox, Acorn, Paramount, tennis channel, sometimes Prime... NOT good!  

I just went to do an update and all I'm told is that I am up to date with the OS 10.5.  I thought a rollback was distributed? 

Lane03
Level 10

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

I had to manually check for updates. If you're not seeing it, maybe it's still being distributed? One thing of note, after rolling back to v10, none of the channels would even launch. I had to then "check for updates" again, which then "updated" all my channels. Then things started working properly again.IMG_20211124_094405~2.jpg

 

MissG2021
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

I tried your suggestion and the Insignia Roku Tv did not update since it already checked for updates. I cannot watch CNBC without the channel shutting down throughout the day, losing the volume, and the audio and video not syncing. This has been going on for 2 weeks. Same thing with my other Roku Tvs thought the house. What is up????

MissG2021
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

How did you roll back the update?

Dani44
Level 8

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

Hey @AzKeW 

Did you get a fix yet?  Mine still is technically frozen, can't get remote to function to get into settings.  Danny said that he sent it to tech support & they will assist, this was last nite.  He's probably slammed with PM's but he was nice enough to reply to mine. 

Psugalen
Level 9

Re: [OS 10.5] Roku TV experiencing loading channel issues

Jump to solution

Yes, I actually kept searching for a software update and finally it showed me the option to roll back to the previous version about one hour ago. All my apps seem to be working fine again! I hope it stays this way.