Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
RokuDanny-R
Roku Employee
Roku Employee

Re: No Airplay connect code appearing on Roku

Hi everyone,

Thanks for the posts.

When trying to use Airplay, have you made sure that both the Roku device and what you are trying to connect are on the same wireless network?


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
davmwill
Level 8

Re: No Airplay connect code appearing on Roku

Yes, they are on the same network. Every device in my house is on the same network. I can control all my Roku devices and Anova Sous Vide with my tablet and iPhones. I just cannot get get Airplay and Homekit to work. 

Sholden81
Level 7

Re: No Airplay connect code appearing on Roku

this is what it looks like in my settings. I have an iPhone 8+

Automatically airplay to TV’s - ON

Transfer to HomePod - this is switched to on

Handoff is switched to on

there Is nothing about asking for a code, or is there a code popping up on my Roku. 

MimaM
Level 7

Re: No Airplay connect code appearing on Roku

are we ever going to get a reply on how to fix this? We all see the same settings, I’m sure we’ve all rebooted and we’re all connected to the same network. How do we get the code???

RichClose
Level 8

Re: No Airplay connect code appearing on Roku

HORRIBLE SUPPORT from ROKU, this is disgusting that they can't solve what appears to be the problem in THEIR design and they just keep quite and offer zero help or even a hint that they care. I'm disgusted with them,

davmwill
Level 8

Re: No Airplay connect code appearing on Roku - Solved

I finally found what was causing my problem I think. I recently obtained an iPhone 6 hand-me-down and in setting it up I neglected to turn on WIFI usage in addition to just the ATT phone connection. You must have all devices on the same WIFI network, install the applicable app on your Apple device (HBO Max in my case), set Airplay to on and whatever setting you want for access (ie code once only, always, or password), open the app, find the tv show you want to stream, click on the Airplay icon, select the Roku device you want from the list (I have 3 in my home), enter the code for the specific Roku device that appears as requested or password if that was your choice, then click on the Play arrow in the HBO Max app. Is it simple or user friendly? You decide. If you have Airplay as a choice on Roku Setup and an Apple device (phone, tablet, laptop, etc.) you should be able to get it to work. I got HBO Max for a year for free with my ATT high speed internet connection and I wanted to binge Sopranos.

0 Kudos
Bittner37
Level 7

Re: Airplay issue with QR code

I have same issue. Airplay works but I get and error message when I try to connect to HomeKit 

Gencap
Level 7

Re: No Airplay connect code appearing on Roku - Solved

No code shows up on my roku.  When I push airplay on ipad it finds my roku the ask for a code.  There is no code.  On my ipad the airplay settings seem different than what you are describing.  One  section says auto connect to airplay: never, ask, aromatic. I have auto checked. Another part is handoff and I have that clicked. Every divide in my house is on the same WiFi. I don't think when I hit airplay if it wasn't it would not let me try to connect. It just doesn't give me a code. 

0 Kudos
Judylou
Level 7

Re: No Airplay connect code appearing on Roku

In settings, air play and handoff is  on automatic. Please help - air play was working and now it is not.  How do I get the code?


@RokuDanny-R wrote:

Hi everyone,

Thanks for the posts.

Can you go to AirPlay in settings and let us know what you see in there?
 
The settings should be
Airplay: On
Require code: First time Only
Subtitles captioning
About Airplay
 
If you see something different, can you please let us know what you are seeing?


Thanks,
Danny

 

0 Kudos
Judylou
Level 7

Re: No Airplay connect code appearing on Roku

Automatic Air Plays to TV

 

Handoff is enabled in green.

 

Hope you can help!

 

Thanks,  Judylou

0 Kudos