Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Search instead for 
Did you mean: 
bobjr94
Level 7

How to enable DD+ to DD transocding on Ultra

I just bought the roku ultra because it says on the website it supports audio transcoding from dolby digital + (netflix) to dolby digital, to allow playback on older tv's and receivers that do not support DD+. I can not find that option listed anywhere in the set-up menus and I was wondering how to access it.
0 Kudos
18 Replies
atc98092
Level 13

Re: How to enable DD+ to DD transocding on Ultra

Did you buy the current model 4660, or last year's 4640? Only the 4640 has the DD decoder. The 4660 cannot convert DD+ to DD. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
kpfleming
Level 7

Re: How to enable DD+ to DD transocding on Ultra

Please post a link to the Roku website page which says this, if it does. Many of us would like to have this feature, but has was pointed out above the current model (which does not have an optical audio output) does not provide it.
0 Kudos
bobjr94
Level 7

Re: How to enable DD+ to DD transocding on Ultra

It says the ultra model will transcode dd+ on their set up guide. If that information is wrong they need to remove that section, that is why I upgraded to the ultra, I may as well being it back and keep using my old one if it's no longer available.

It's about 3\4 of the way down on this page.

https://support.roku.com/article/208754 ... ound-sound
0 Kudos
starl1te
Level 8

Re: How to enable DD+ to DD transocding on Ultra

if your ultra doesn't have an optical port it means it's the new one and will not transcode to DD

you can still get the old ultras in canada (eg, the Roku Canada online store, bestbuy.ca etc)

by the way even the old one is currently bugged and will not transcode DD via HDMI (it will via optical)
0 Kudos
Andyg53
Level 7

Re: How to enable DD+ to DD transocding on Ultra

I just tried to connect an optical cable to my 4640 and did not get DD, only stereo.
0 Kudos
twiceover
Level 10

Re: How to enable DD+ to DD transocding on Ultra

"Andyg53" wrote:
I just tried to connect an optical cable to my 4640 and did not get DD, only stereo.


Did you set the spdif setting to DD? Auto will not work.
0 Kudos
atc98092
Level 13

Re: How to enable DD+ to DD transocding on Ultra

"Andyg53" wrote:
I just tried to connect an optical cable to my 4640 and did not get DD, only stereo.

That's a bug that has been well discussed here. Roku is working on it, but we never hear about any coming updates or what they fix. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Andyg53
Level 7

Re: How to enable DD+ to DD transocding on Ultra

Yes, I tried the s/pdif setting with both DD and DD/DTS. 
0 Kudos
azurenepsa
Level 7

Re: How to enable DD+ to DD transocding on Ultra

"Andyg53" wrote:
Yes, I tried the s/pdif setting with both DD and DD/DTS. 

Did you try removing the optical cable from the AV receiver just to make sure you don't hear any audio after doing so?  If you do hear audio, this would mean that the HDMI audio feed is somehow coming through.

If you don't hear any audio, the bug must be affecting you even over optical.  The Roku OS seems to have a penchant for behaving in very different ways depending on what sort of AV devices one has.
0 Kudos