Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
makaiguy
Level 21

Help setting up Apple Airplay on Roku

Jump to solution

Let me state up front that I am not an Apple guy.  My wife has a current iPad Mini 5 that includes Airplay but that's the only Apple device we have in the whole house.

I have two Rokus on 9.4 that include Airplay capabilities.  I have Airplay turned on on both Rokus.  I could swear when this first came out I experimented and got my Streaming Stick+ to stream from the iPad via Airplay, but now when we click the Airplay icon while viewing a video on the iPad, the only device shown in the iPad Airplay popup on the iPad is the iPad itself.  iPad and my Rokus are connected to the same local net, and the Roku app on my phone connected to the same net sees all of my Rokus.

Where do I go from here?

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
1 Solution

Accepted Solutions
StreamerUser
Community Streaming Expert

Re: Help setting up Apple Airplay on Roku

Jump to solution

This appears to be a recurring issue with the AirPlay2 support, however:

1)  Reset the paired devices: Settings/Apple Airplay and HomeKit/Require Code/Reset Paired Devices - try again

2) Try disabling/re-enabling WIFi on the Apple devices - try again

3) Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz - try again

4) Restart all devices (Rokus, Apples, router/modem) - try again

5) Switch Roku's display output to 1080p - try again

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

7 Replies
StreamerUser
Community Streaming Expert

Re: Help setting up Apple Airplay on Roku

Jump to solution

This appears to be a recurring issue with the AirPlay2 support, however:

1)  Reset the paired devices: Settings/Apple Airplay and HomeKit/Require Code/Reset Paired Devices - try again

2) Try disabling/re-enabling WIFi on the Apple devices - try again

3) Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz - try again

4) Restart all devices (Rokus, Apples, router/modem) - try again

5) Switch Roku's display output to 1080p - try again

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

makaiguy
Level 21

Re: Help setting up Apple Airplay on Roku

Jump to solution

Thanks, I'll give these a try when I can get the iPad back out of my wife's hands for a while ...

Stick+  already set to 1080p by the way.

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
makaiguy
Level 21

Re: Help setting up Apple Airplay on Roku

Jump to solution

I guess I got lucky. All it took for me was disabling/re-enabling WIFi on the sole Apple device.

Thanks for your help, @StreamerUser 

  • Roku Streaming Stick +, 3810X, Ser YH0059427035, wifi - Samsung UN55ES6100
  • Roku Streaming Stick, 3600X, Ser 5S56D8240827, wifi - JVC EM37T
  • TCL Roku TV 43S425/C107X, Ser X000001R60KV, wifi
0 Kudos
StreamerUser
Community Streaming Expert

Re: Help setting up Apple Airplay on Roku

Jump to solution

Thats actually the most common "fix" for mirroring/casting issues - and the easiest to try/do, so it works out well when thats all it takes.

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Barmeister50
Level 7

Re: Help setting up Apple Airplay on Roku

Jump to solution

tried these steps several times and does seem to work for me

9102R Roku Streambar Software version 9.4.6 - Build 4013-95 Music plays fine, Photos seem to work...  videos message no supported format...  Videos play fine on Apple devices and even when streamed Airplay 2 through Apple TV Plus, butr not through Roku's AirPlay

0 Kudos
jellyjam
Level 7

Re: Help setting up Apple Airplay on Roku

Jump to solution

I tried all of the suggestions above to no avail, factory resetting it a couple times too.

Have a Roku Streambar that’s worked great for months before suddenly glitching like this. The Roku doesn’t show up in options to screen mirror/connect, including in apps like Youtube or Netflix, and I’ve made sure all of the requirements and permissions are allowed.

The Apple AirPlay and HomeKit settings show up and I can turn AirPlay on and off, but it doesn’t change anything.

Multiple different iPhones haven’t worked, and I’ve made sure that they’re on the same network.

Bluetooth and music work fine, but AirPlay does not.

Also occasionally (randomly), when opening the AirPlay menu, it gives me a message about freeing up space, but still happened after I factory reset and only had a few apps.

Really don’t know what’s going on.

Model - 9102CA

Software Ver. - 9.4.6 build 4013-95

 

0 Kudos
StreamerUser
Community Streaming Expert

Re: Help setting up Apple Airplay on Roku

Jump to solution

Both of you Streambar users need to report your AP issues to Roku & Apple:

Roku chat or email:   https://support.roku.com/contactus/contact-options  (choose setup/streambar/other/need more help?)

Apple: https://support.apple.com/en-us/HT204291   https://support.apple.com/contact

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos