Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Closed Captioning always on

I can't seem to keep Closed Captioning off.  Everyone time I turn on my ROKU TV, I have to manually go and change the CC to off.  I can open an app and it'll be off but if I close that app and then go into another app, I have to go and turn off CC again...this is happening all the time.  I want to be able to turn off CC and keep it off! I'm about ready to throw out all my ROKU TVs because of this!! Help!!!!!!!!!!!!!  (and this doesn't happen on the one Fire TV I have, the CC stays off so it isn't an app issue, more of a ROKU issue)

15 Replies
Level 7

Re: Closed Captioning always on

It's a daily chore. You get the standard instruction to reset the settings but it's back every time.  If they don't fix it soon they really Skkkk.

Level 7

Re: Closed Captioning always on

Fix this, why do i have to reset this every time I log on.

Level 7

Re: Closed Captioning always on

Hey Guys,

I'm having a similar problem. Doesn't happen ALL the time, but CC does seem to turn itself on by itself. I've checked to make sure the shortcut is disabled, but that doesn't seem to keep it from turning itself on. I find it hugely annoying. Why would you put a option for ALWAYS ON, but not have an option ALWAYS OFF? 

 

Level 7

Re: Closed Captioning always on

I am having the same problem too.  The problem is happening on my 3 Roku TV's and my Roku Ultra streaming player.  I do have an older Roku 3 streaming player where the Closed Caption does not revert back to "always on".  This is very annoying having to reset it everyday.  

Level 7

Re: Closed Captioning always on

Hey ROKU people. Please fix this...   Laurie1

Level 7

Re: Closed Captioning always on

This has just started for me too. It first started with Amazon prime, then Hulu, and now Netflix. It's so infuriating! Has anyone gotten an answer as to why there's not a way to set it to always off?

Level 7

Re: Closed Captioning always on

We figured it out... I think I went back to the General Settings for Roku, set it to always off. Which turned them all off.

0 Kudos
Level 7

Re: Closed Captioning always on

This just started with the 9.4 update. I like to keep closed captions on mute only. But now it goes to on all the time. It is on live tv that it happens the most. 

Level 8

Re: Closed Captioning always on

Same thing just started happening to me, especially live tv.