Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Kristine1215
Level 7

Cannot set to “home mode”/No Power Settings

Hello, I’ve had my Roku Ultra for a while now but I’ve gotten tired of it turning back on, on it’s own and my power options in the “settings > system” menu isn’t showing.

I looked into this, found that my issue is my Roku is set to store mode instead of home mode (as if it were a display model at a store.)

I’ve factory reset my Roku twice to change it to home mode but I don’t see anywhere during the setup process to set this, so I’m still without the power settings. 

Any advice is appreciated, thanks for reading.

0 Kudos
4 REPLIES 4\
renojim
Community Streaming Expert

Re: Cannot set to “home mode”/No Power Settings

Only TVs have power options.  It's not clear what you're trying to say, but I've never seen a "store mode" on any standalone Roku.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
makaiguy
Community Streaming Expert

Re: Cannot set to “home mode”/No Power Settings


@Kristine1215 wrote:

Hello, I’ve had my Roku Ultra for a while now but I’ve gotten tired of it turning back on, on it’s own and my power options in the “settings > system” menu isn’t showing.

I looked into this, found that my issue is my Roku is set to store mode instead of home mode (as if it were a display model at a store.)

I’ve factory reset my Roku twice to change it to home mode but I don’t see anywhere during the setup process to set this, so I’m still without the power settings. 

Any advice is appreciated, thanks for reading.


As already indicated, store/demo mode is only present in Roku TVs, i.e. sets with Roku functionality built in, not in separate streaming devices like the Ultra that are then connected to a TV.  And the Ultra, taking its power by being plugged into a wall outlet is always on, so it doesn't "turn on".

I suspect what may be occurring is that your TV may be turning on and/or automatically switching from some other input to the HDMI input to which the Roku is connected seemingly on its own.  This could be in response to the Roku remote being bumped or jostled and sending a keypress response to the TV through the CEC (Consumer Electronics Control) capabilties of both the Roku and the TV. 

You can turn off CEC in the Roku, where this function is called "1-touch play".  From the Roku home screen you'll find this setting via menu path Settings/System/Control other devices/1-touch play.  After unchecking the box, restart the Roku via Settings/System/System restart.

If this behavior continues, you may have to disable CEC on the TV.  On some TVs only specified HDMI inputs have CEC, so plugging the Roku into a non-CEC port should stop this behavior.  You may also be able to disable CEC in the TV settings.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Do not ask me support questions via private message -- post them publicly to the Community where others may benefit as well.

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600
0 Kudos
TaraM
Level 7

Re: Cannot set to “home mode”/No Power Settings

i’m having the same problem , it’s happened to me before. it’s an LG tv and i have the roku express 

i get this pop up menu blocking the screen every 30 seconds 

ive got to search through all these posts to find where i got the answer , because i did finally get a pathway to turn off “retail mode” eventuslly

 

when i google how to get it off of store/retail mode the instructions don’t match what my roku settings options are. 

it has nothing to do with my tv, it’s a roku thing

if i find the answer i’ll let you know 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Cannot set to “home mode”/No Power Settings

@TaraM 

Depending on which operating system is on your LG smartTV, I think you will find the answer is the Mode Setting on your TV. (https://www.techsolutions.support.com/how-to/how-to-turn-off-demo-mode-on-a-lg-smart-tv-11015).

You will need to use your TV's remote (not the Roku remote).

Feel free to post a screenshot of the pop-up message you are seeing.  (just use that little Photos camera icon above).

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos