Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Cannot get screen mirroring to work via direct wifi using any device

So I absolutely cannot get my Roku express to mirror the screen from any of my phone's (an LG Stylo 5 or a Moto g stylus) or my computer, which runs on windows 10. My brother has the exact same roku as me and is one room away and uses screen mirroring all the time. For some reason, whenever I try, it will say it is connected and take me to the screen where it is connecting, my devices name will be listed at the bottom of the TV and a bar will be on the TV, yet it will get stuck at halfway across, so the screen will never actually start mirroring. I've checked to see if it's updated- it is. I've turned it off and on...nothing works. I'm at a loss of what to do here. I think I may have just got a **bleep** Roku. Since I can't watch HBO max on Roku, I was hoping to st least be able to mirror it onto my screen.

9 Replies
Level 14

Re: Cannot get screen mirroring to work via direct wifi using any device

1.) Go to Settings/System/Screen Mirroring/Screen Mirroring Devices and remove all allowed and blocked devices.

2.) Go to Settings/System/Screen Mirroring/Screen Mirroring Mode and set it (and leave it) at Prompt.  If your Roku is "always on", Restart the Roku.

3.) Disable the WiFi on your phone, re-enable the WiFi on your phone, then attempt to screen share it to the detected Roku (make sure its the correct Roku - yours, not your brother's) - be patient, connecting can sometimes take 30-60 seconds.

4.) Once connected, you will be presented with a dialog box with the following choices:  "Always Allow, Allow, Block, Always Block" - choose  Always Allow (your device will then be listed under allowed devices once it successfully connects).

5.) If you ever have trouble connecting after that, first try Disabling/Enabling WiFi on your phone - If you still cant connect, restart the Roku, then Disable/Enable WiFi on your phone and try again.

Note 1:  Since the Express is a 2.4Ghz-only device, and since Miracast (mirroring/screen sharing) prefers 2.4Ghz for negotiation, make sure your phone is connected to your wireless network via 2.4Ghz before screen sharing if you're having problems.

Note 2: Do not manually use/connect the WiFi Direct function in your phone before screen sharing (the phone's/devices screen sharing function will handle all this).

0 Kudos
Level 7

Re: Cannot get screen mirroring to work via direct wifi using any device

Okay, so both of my phone's, that I know of, don't have any screen mirroring options on them. The only way to connect them is via the manual direct connect with wifi. Is there an app that I can use that actually works? Also, I don't actually have any phone's listed on my allowed devices, it wouldn't let me put anything on there, even once the phones were connected. I don't understand the 2.4 GHz thing either. Is that what kind of wifi I'm on or ....sorry, I'm not very "techy"

0 Kudos
Level 21

Re: Cannot get screen mirroring to work via direct wifi using any device

I had a Samsung S8, and it screen mirrored with my Ultra 4640 without a problem. I had to install an app, but it's been too long and I don't remember what the app was. I no longer have any Android phone, so can't say what works now.

For Windows computers, you have two requirements that I am aware of. The computer must have a wireless adapter, and that adapter and your video card must support Miracast. I cannot mirror any of my Windows desktop PCs, as none have a wireless card. The laptop I am currently using will screen mirror with no problem to any of my Roku devices (players and TVs). 

On your Windows 10 computer, run DXDIAG and save the results. In the saved file, look for this line:

Miracast: Available, with HDCP

This is what my laptop reports. If Miracast isn't available on your computer, it will say so here, and you won't be able to screen mirror. I tried it on one of my desktop PCs, and it reported Miracast: Available, no HDCP. So if I added a wireless card to that computer, I would be able to screen mirror from it as well.

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Level 14

Re: Cannot get screen mirroring to work via direct wifi using any device

LG Stylo 5:

https://www.verizon.com/support/knowledge-base-227789/

Follow these steps to view your entire screen contents on your TV.

  1. From a Home screen, navigate: Settings Settings icon > Connected devices Connected devices icon.
  2. Tap Screen sharing.
  3. Tap the Screen sharing switch to it turn on On switch icon or off Off switch icon.
    NoteOnce turned on, your device locates compatible displays.

Moto G Stylus:

https://www.verizon.com/support/knowledge-base-230551/

  1. From a Home screen, swipe up to display all apps.
  2. Navigate: Settings Settings icon > Connected devices Connected devices icon.
  3. Tap Connection preferences.
  4. Tap Cast.
  5. Select an available device (e.g., smart TV or laptop).
0 Kudos
Level 7

Re: Cannot get screen mirroring to work via direct wifi using any device

Okay so I was having the same problem as the OP and I followed your steps 1-4 and they worked fine then it prompts me saying that RokuCast may not work if not connected to a WiFi network and it has an option to connect to network or to proceed anyways. I clicked proceed anyways and then it took me right back to the screen where it says "Starting video from LG Stylo 5... The loading bar starts at almost halfway and stays there, never moved any, and didn't start at 0, just began at almost halfway and stays there. There's 2 options on the same screen, one is for "options" and the other is "stop video". Yet with my Roku remote it won't let me click or use either option and if I press the okay button on the remote it just cancels that screen and goes back to Rokus Home screen. I have no home internet. No router. No wifi of any kind. Just my 4G LTE data on my phone. So I can't connect my phone and Roku to the same wifi network. I assumed WiFi Direct would take place of the internet enabled wifi but obviously something is missing or I'm doing something wrong maybe. The issue is you say not to enable the wifi direct until you enable the screen sharing option on your phone but the LG Stylo 5 doesn't have that option anywhere. It's advertised that it does but I'm guessing an update removed that capability. So question is... Where in the world do I go from here to be able to screen share from my Stylo 5 to my Roku TV??? The other bad thing is that the Stylo 5 isn't MHL or SlimPort capable natively so I can't use a wired connection. And I thought maybe I could buy a MiraCast dongle and just turn my TV to that HDMI port the dongle is plugged into but then the issue of my phone not having the screen share/MiraCast capability comes back into play. I've tried several MiraCast screen mirroring apps to no avail. Any suggestions StreamerUser? Or anyone else?

0 Kudos
Level 21

Re: Cannot get screen mirroring to work via direct wifi using any device


@JayBee93 wrote:

Okay so I was having the same problem as the OP and I followed your steps 1-4 and they worked fine then it prompts me saying that RokuCast may not work if not connected to a WiFi network and it has an option to connect to network or to proceed anyways. I clicked proceed anyways and then it took me right back to the screen where it says "Starting video from LG Stylo 5... The loading bar starts at almost halfway and stays there, never moved any, and didn't start at 0, just began at almost halfway and stays there. There's 2 options on the same screen, one is for "options" and the other is "stop video". Yet with my Roku remote it won't let me click or use either option and if I press the okay button on the remote it just cancels that screen and goes back to Rokus Home screen. I have no home internet. No router. No wifi of any kind. Just my 4G LTE data on my phone. So I can't connect my phone and Roku to the same wifi network. I assumed WiFi Direct would take place of the internet enabled wifi but obviously something is missing or I'm doing something wrong maybe. The issue is you say not to enable the wifi direct until you enable the screen sharing option on your phone but the LG Stylo 5 doesn't have that option anywhere. It's advertised that it does but I'm guessing an update removed that capability. So question is... Where in the world do I go from here to be able to screen share from my Stylo 5 to my Roku TV??? The other bad thing is that the Stylo 5 isn't MHL or SlimPort capable natively so I can't use a wired connection. And I thought maybe I could buy a MiraCast dongle and just turn my TV to that HDMI port the dongle is plugged into but then the issue of my phone not having the screen share/MiraCast capability comes back into play. I've tried several MiraCast screen mirroring apps to no avail. Any suggestions StreamerUser? Or anyone else?


To my knowledge, when a phone is providing a hotspot it does not allow the phone and any connected device to see each other. That's done for security reasons. If your phone is your only network, I don't believe there's any way to screen share to a Roku, or any other device. You could set up a router, and even though it wouldn't have any Internet access it would permit a local, in-house wireless network. In that case, the TV and the phone could both connect to the router and then be able to screen share. Of course, without Internet access via the router, the only thing you'd be able to share from the phone is content already on the phone itself. I don't know of any way to use a WiFi connection and the cellular data connection at the same time. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Level 7

Re: Cannot get screen mirroring to work via direct wifi using any device

The key for my Roku streaming Stick working with my LG Miracast tablet was 2.4g. It would occasionally find the Roku and populate it under the 5G settings of my modem but as soon as I went and connected to the 2.4g it came up every time and worked consistently for once.

0 Kudos
Level 7

Re: Cannot get screen mirroring to work via direct wifi using any device


@StreamerUser wrote:

1.) Go to Settings/System/Screen Mirroring/Screen Mirroring Devices and remove all allowed and blocked devices.

2.) Go to Settings/System/Screen Mirroring/Screen Mirroring Mode and set it (and leave it) at Prompt.  If your Roku is "always on", Restart the Roku.

3.) Disable the WiFi on your phone, re-enable the WiFi on your phone, then attempt to screen share it to the detected Roku (make sure its the correct Roku - yours, not your brother's) - be patient, connecting can sometimes take 30-60 seconds.

4.) Once connected, you will be presented with a dialog box with the following choices:  "Always Allow, Allow, Block, Always Block" - choose  Always Allow (your device will then be listed under allowed devices once it successfully connects).

5.) If you ever have trouble connecting after that, first try Disabling/Enabling WiFi on your phone - If you still cant connect, restart the Roku, then Disable/Enable WiFi on your phone and try again.

Note 1:  Since the Express is a 2.4Ghz-only device, and since Miracast (mirroring/screen sharing) prefers 2.4Ghz for negotiation, make sure your phone is connected to your wireless network via 2.4Ghz before screen sharing if you're having problems.

Note 2: Do not manually use/connect the WiFi Direct function in your phone before screen sharing (the phone's/devices screen sharing function will handle all this).



Followed on Win10.  Connects to the point of prompting for always, etc. and lists the device (the PC) in the allowed list but never fully connects.  Get an error on PC saying couldn't connect, Roku shows 1/3 progress bar, eventually returns to home screen.  Wireless connection is Private net, played with firewall on/off, sharing settings on/off, different wireless connections at different speeds/types (all on same net - PC, Roku, and iPhone).  All get to same point and fail.

Ideas?

0 Kudos
Level 7

Re: Cannot get screen mirroring to work via direct wifi using any device

I had the same problem as described by Brolysmom. at the top  In the end, I decided that the problem is that the Roku device has a really short timeout.  I was using a laptop with a hard disk to connect.  The laptop was too slow to respond to Roku because it was reading some information from the hard disk.

My solution was to reboot the Windows laptop and not run any applications.  If the laptop was slow to reboot, then I would reboot still again.  Then I would connect in the normal way (windows key-P, and choose devices).  It still wouldn't connect, but it would get a little farther.  Then I would click on "reconnect", or else start the request again from windows-P.  After two or three re-connects, eventually, it does connect.

I believe that something in the Roku software is using too short a timeout.  Maybe the software developers had more powerful laptops/phones that they used to connect when testing their software.

0 Kudos