Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Gina95r
Level 7

Airplay stopped working after changing wifi (still works with ethernet cable or on personal hotspot)

Hello..

I've been using airplay just fine for a couple of months on my Roku Express+. I recently moved across continents and with my new wifi airplay is not working anymore, I have to guess the problem is related to the router settings but I have no idea how to fix it.

P.s: I connected my laptop and Roku to my phone's hotspot and airplay still works fine, it is just on my wifi that it is not working.

Since every router setting panel is different I'll add pictures.

Someone help me please!!

Screen Shot 2021-07-03 at 1.14.01 PM.pngScreen Shot 2021-07-03 at 1.13.54 PM.pngScreen Shot 2021-07-03 at 1.13.49 PM.pngScreen Shot 2021-07-03 at 1.13.36 PM.pngOne thing that I did notice is that when I connect Roku to the wifi, the IP for the internet is different to the one on my laptop, the one in my laptop is the same as it says up there in the pictures and the one on Roku is different and idk why.

Tags (1)
0 Kudos
13 REPLIES 13\
StreamerUser
Level 20

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

You didnt mention your Roku model # or firmware version:  Settings/System/About

Test DIAL-based casting:  Open the YT app on your phone, press the Cast icon, see if your Roku shows up - if it does, proceed to the AirPlay steps, it doesnt, start with modem/etc setup.

Modem/router/gateway setup:

1) I notice your modem/router/gateway is 2.4Ghz-only - while this wont make any difference to your Express+, it might make a difference to your laptop or other dual-band/5Ghz-capable devices.

2) Enable Short Preamble (unless you have "B" device) and MU-MIMO

3) Change the band to G/N/AC (unless you have ancient "B" devices), and if 5Ghz is available, enable that too, the Channel Width to Auto or 20Mhz, the Channel to 1, 6, or 11 ( not sure where you are).

4) The IP address shown there is the LAN-side (not WAN/Internet) IP address of the modem/router/gateway itself - none of your devices should show that as their IP (verify you are reading the information correctl) - reboot/restart all devices after making the listed changes.

AirPlay troubleshooting:

1) Verify you have the latest AirPlay support:
   A) Using remote: Home 3x, Up 2x, L, R, L, R, L (AirPlay should be 1.1.14-104 or later)
   B) Settings/System/System update/Check now (should be 10.0.0-4195 or later) - try again

2) Disable & Re-enable WiFi on the Apple devices - try again

3) Restart all devices (Rokus, Apples, router/modem) - try again

4) Reset the paired devices: Settings/Apple Airplay and HomeKit/Require Code/Reset Paired Devices - try again

5) Setup HomeKit: Settings/Apple Airplay and HomeKit/Setup HomeKit - try again

6) Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz - try again

7) Switch Roku's display output to 1080p - try again

Gina95r
Level 7

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

Thank you so much for the fast reply.

I made all of the changes (I think) but Roku is still not showing up on my devices (macbook pro big sur 11.4) and iphone 12 ios 14.6)

I also restarted all 3 the devices multiple times.

Roku model: 3910MX Roku Express+

Software 10.0.0 (4209-51)

The only doubt I have is about the band because I have different options than G/N/AC and there's no 5Ghz option.

Also I don't know how to "Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz " hehe 

I'll add screen captures but in a google drive link because I can't seem to be able to add pictures in replies

https://drive.google.com/drive/folders/1ol4mUifHCsI6qFjEh2AUG51XuYI3u1-H?usp=sharing 

Again, I know that airplay works because if I connect to my phone's internet then I can airplay form my laptop to Roku just fine.

Hope someone we can figure this out soon Smiley Sad

0 Kudos
Gina95r
Level 7

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

Hello, thank you so much for your help.

I made all of the changes you told me (I think), the only doubt I have is regarding the band because I don't have the exact options you're telling me as you can see in the picture below

Screen Shot 2021-07-04 at 12.05.56 PM.png

Here you can see all the changes (I tried with channel 1, 6 and also 11).Screen Shot 2021-07-04 at 12.05.50 PM.pngScreen Shot 2021-07-04 at 12.05.42 PM.png

Saldy, it didn't work, the cast option on youtube doesn't work either, and as I said before I don't think the problem is a Roku or laptop setting because when I use other wifi signal like my phone's hotspot airplay works just fine, so I'm like 99% sure it is something regarding the router settings.

If you figure out any other setting that I can change please tell me.

Again, thank you.

0 Kudos
Gina95r
Level 7

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

Here are more setting options so you can see if there's anything else I can change

Screen Shot 2021-07-06 at 3.18.25 PM.pngScreen Shot 2021-07-06 at 3.18.36 PM.pngScreen Shot 2021-07-06 at 3.18.47 PM.pngScreen Shot 2021-07-06 at 3.18.52 PM.pngScreen Shot 2021-07-06 at 3.18.56 PM.pngScreen Shot 2021-07-06 at 3.19.01 PM.pngScreen Shot 2021-07-06 at 3.19.26 PM.pngScreen Shot 2021-07-06 at 3.19.34 PM.pngScreen Shot 2021-07-06 at 3.19.41 PM.pngScreen Shot 2021-07-06 at 3.20.59 PM.png


 

0 Kudos
StreamerUser
Level 20

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

1)  You cant manually switch between 2.4Ghz and 5Ghz unless your AP supports 5Ghz, and it has a separate SSID from 2.4Ghz (your modem/router/gateway doesnt have 5Ghz support, so this is moot)

2) Try disabling "IGMP snooping" and "Multicast to Unicast".

3) Make sure you enable/arent blocking any kind of multicast/mDNS/DNS-SD/Bonjour etc - check under Services or Advanced.

3) If you connect the laptop to the modem/router/gateway wired (ethernet), can you AirPlay then?

0 Kudos
Gina95r
Level 7

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

Sorry, I've been busy with work but now that I'm on a break I can get back to setting this up, it would be useful these days being able to cast the olympics to my tv haha

I don't have a ethernet adapter but I just ordered one online, I'll let you know next week.

I made the changes and checked out multicast and DNS, everything seems fineScreen Shot 2021-08-01 at 11.08.20 AM.pngScreen Shot 2021-08-01 at 11.08.24 AM.png

 

I did noticed something, I don't know if it is useful information but, using my phone hotspot, if I disable the "maximize compatibility" option Roku disappears on Airplay, I made some research and I guess maximise compatibility means enabling  5Ghz? So that means either Roku or my laptop needs 5Ghz connection to airplay? But my router doesn't have a 5Ghz option so is there anything I can change on my macbook or Roku so it works with 2.4Ghz instead? 

 

Also sometimes this shows up under the wifi toggle on my laptop

Screen Shot 2021-08-01 at 11.15.03 AM.png

Tags (1)
0 Kudos
StreamerUser
Level 20

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

1)  Hopefully the ethernet adapter is for your laptop - the 3910 doesnt support USB ethernet adapters.

2) "Maximize compatability" turns on 2.4Ghz and turns off 5Ghz - disabling it should make the Roku disappear, since the 3910 doesnt support 5Ghz (it only supports 2.4Ghz), so leave MC enabled.

3) You forgot to make a change I suggested:   "3) Change the band to G/N/AC (unless you have ancient "B" devices), and if 5Ghz is available, enable that too, the Channel Width to Auto or 20Mhz, the Channel to 1, 6, or 11 ( not sure where you are)." which is why your laptop (and maybe Roku too) is using "B" mode to connect - you need to disable B mode in your WLAN Basic settings "Band" setting.

0 Kudos
Gina95r
Level 7

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

Hello! I'm back after summer break. 

Following up...

1) Yes it worked with my laptop, and YES when I connect my laptop via ethernet cable Roku shows up on Airplay and works perfectly, so hopefully you know what that means hehe.

2) Ok I leave it on

3) Originally I did change it, I was just messing around with some random changes, but I changed it back to G+N and that is not making it work.

 

0 Kudos
StreamerUser
Level 20

Re: Airplay stopped working after changing wifi (still works on personal hotspot)

1) It means AirPlay is working in general for the Roku, the modem/router/gateway, and the Laptop - what isnt working is when the Laptop is connected via WiFi to the modem/router/gateway (it suggests Client/AP isolation or other filtering is enabled in the modem/router/gateway, since HotSpot WiFi allows AirPlay discovery etc)

2) Good - keep "Maximize Compatibility" enabled whenever you use your Phone as a HotSpot.

3)  Not clear what you changed when, or when it does/doesnt work - make sure B mode is disabled in the modem/router/gateway settings (G/N only).

You never fully checked this:

4) Make sure you enable/arent blocking any kind of multicast/mDNS/DNS-SD/Bonjour/etc in your modem/router/gateway settings - check under Services or Advanced.  (post some screenshots from the advanced section).

5) You never posted screenshots from the UPnP section (allow UPnP/SSDP for YouTube/Netflix casting)

6) Verify IGMP Snooping is disabled.

Bottom Line:

Ultimately we know the Roku's AirPlay is working without issue, since it works with phone HotSpot and the modem/router/gateway (when laptop is ethernet connected), so this is purely an issue with the laptop and modem/router/gateway WiFi.

I highly recommend you post in both Apple's Airplay support forums, and your ISP's support forums (since this isnt really a Roku issue) from this point forward.

0 Kudos