Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Maggzzz
Level 7

Airplay cannot stream on Roku express

I have a Roku Express 3930X currently running on 10.0. I was able to stream videos on webpages (Safari) using Airplay until a week ago. I can use the screen monitoring function but whenever I stream something, my tv screen is stuck with the Airplay settings page or a black screen. Wondering if anyone has had the same problem and has solved it? 

0 Kudos
1 REPLY 1\
StreamerUser
Community Streaming Expert

Re: Airplay cannot stream on Roku express


@Maggzzz wrote:

I have a Roku Express 3930X currently running on 10.0. I was able to stream videos on webpages (Safari) using Airplay until a week ago. I can use the screen monitoring function but whenever I stream something, my tv screen is stuck with the Airplay settings page or a black screen. Wondering if anyone has had the same problem and has solved it? 


While you did mention your model name, #, and firmware version partially, you left out the build (it matters, especially for AirPlay):  Settings/System/About

However, this appears to be a recurring issue with the AirPlay2 support.

1) Verify you have the latest AirPlay support:  Settings/System/System update/Check now (should be 10.0.0-4209 or later) - try again

2) Verify your devices arent connected to a Guest SSID or otherwise have AP/Client Isolation enabled on the SSID - try again

3) Disable & re-enable WiFi on the Apple devices - try again

4) Restart all devices (Rokus, Apples, modem/router/gateway) - try again

5) Reset the paired devices: Settings/Apple Airplay and HomeKit/Require Code/Reset Paired Devices - try again

6) Setup HomeKit: Settings/Apple Airplay and HomeKit/Setup HomeKit - try again

7) Switch either Rokus or Apples from 5Ghz to 2.4Ghz, or from 2.4Ghz to 5Ghz - try again

8) Manually configure Roku's display output to 1080p:  Settings/Display type/1080p TV - try again

 

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos