Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
rrobinson
Level 7

Private Channel Upload Problem <solved>

When I try to upload my package I get this message:
The website experienced an unexpected problem

in url bar: https://owner.roku.com/Error.htm?code=500&subcode=0&url=https%3a%2f%2fowner.roku.com%2fDeveloper%2fHome%2fdefault.aspx

When I run an inspect on the package everything looks good.

Any ideas?

Thanks
0 Kudos
7 Replies
RokuKevin
Level 9

Re: Private Channel Upload Problem

I would try the upload again, just to see if the problem is persistent.

--Kevin
0 Kudos
rrobinson
Level 7

Re: Private Channel Upload Problem

I just tried it again and received the same message.
I had tried it two nights in a row before I posted.

thanks
0 Kudos
renojim
Level 10

Re: Private Channel Upload Problem

I had a similar problem when I was running something that was using up a significant portion of my upload bandwidth. When I stopped it, everything was fine. Could there be some kind of timeout happening if it takes too long for the pkg to upload?

-JT
0 Kudos
rrobinson
Level 7

Re: Private Channel Upload Problem

Good question, Thanks for replying.

I checked just to make sure, did a reboot and shut my virus protection off.

I have two networks, one that has a wireless router attached and one not.
I disconnected them one at a time and tried each independently after bypassing
the firewalls ( they are hardware firewalls ). I'm assuming it's http upload but shut them down just to
be sure.

These networks are work only and no one else has access to them.
I used Wireshark( Ethereal ) and process explorer
to make sure there was nothing else running on my local box.

The error happens right about a 4 count.

I thought maybe the directory structure was too deep so I moved it to one off the root and tried.
I read the packaging instructions again and repackaged it using the same key.
Both with the same results.

The sd image is 23.2KB and the hd image is 39.1KB, both 24bit pngs.
The pkg file is 288KB.
This shouldn't take more than about a 4-5 count to upload

I have no spaces in the paths or filenames.

Seems like it has to be something on my end since no one else is having
issues but I'm lost to what it could be.
0 Kudos
RokuKevin
Level 9

Re: Private Channel Upload Problem

That pkg file is too big.... Even large channels are under 50k.

--Kevin
0 Kudos
rrobinson
Level 7

Re: Private Channel Upload Problem

Thanks, it was an orignal package with poster images that are now
being fetched from our server. I removed them and now the package is 59k
Still didn't work...but

We are used to tagging our Program titles with their state ex: <development>
This seems to be what was making it choke. Removed it and it uploaded fine.

Nice forums, great response
0 Kudos
greubel
Level 7

Re: Private Channel Upload Problem <solved>

I have found that it will load packages up to 500K. So I don't think it's the size.
0 Kudos