Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Search instead for 
Did you mean: 
EnTerr
Level 8

Label/Line Not Found. (compile error) mystery

This is what i ran into today:
*** ERROR compiling /pkg:/source/foo.brs:

Label/Line Not Found. (compile error) in ...BF/pkg:/source/foo.brs(break)

That's all i got in console. I am used to getting the line number in parenthesis but not this time - for some reason this time it says "break". I have interrupted the code with ^C in console before indeed but even repeat deployments still got me the same error. The error text sounds as if i was doing GOTO to a wrong location but i wasn't. I double-checked: no goto's anywhere, another cold trail.

Head-scratcher, isn't it? Took me a while to figure it out. I'll leave it without answer for a while - maybe someone likes puzzles and can guess the reason? :idea:

To the invisible man in the sky that writes BRS compiler: do always print the line# where error was detected, can you? That would have helped.
0 Kudos