Roku Developer Program

Developers and content creators—a complete solution for growing an audience directly.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pinehead
Level 7

Error: Missing or invalid PHY

I've been successfully streaming off a custom app up until this week. Then an error occurred that says I've gone as far as using a test script that once worked and found on this forum. I've plugged the stream into the other tests and the same thing happens.


Here is the code to a simple stream video script that used to work and now has randomly stopped. Any input into this would be greatly appreciated.

Sub Main()

vid = {
StreamUrls: ["http://mobile.ec2.cor.org:1935/live/mobile-2/playlist.m3u8"]
streamBitrates: [0]
streamQualities: ["SD"]
streamFormat: "hls"
}

screen = CreateObject("roVideoScreen")
screen.SetMessagePort(CreateObject("roMessagePort"))
screen.SetContent(vid)
screen.Show()

while true
msg = wait(0, screen.GetMessagePort())

if type(msg) = "roVideoScreenEvent" then
if msg.isScreenClosed()
exit while
end if
end if
end while
End Sub


BrightScript Debugger> ------ Running ------
*** ERROR: Missing or invalid PHY
11, 0: startup progress
11, 66: startup progress
11, 132: startup progress
9,-3: An unexpected problem (but not server timeout or HTTP error) has been det
ected.
16, 0: Playback completed.
11, 0: end of playlist
------ Running ------
11, 0: startup progress
11, 66: startup progress
11, 132: startup progress
9,-3: An unexpected problem (but not server timeout or HTTP error) has been det
ected.
16, 0: Playback completed.
11, 0: end of playlist
0 Kudos
4 Replies
Highlighted
Anonymous
Level 8

Re: Error: Missing or invalid PHY

Are you using wireless? Do other channels work?
0 Kudos
Highlighted
pinehead
Level 7

Re: Error: Missing or invalid PHY

No it is a wired connection and yes blip.tv is working.
0 Kudos
Highlighted
RokuKevin
Level 9

Re: Error: Missing or invalid PHY

Please see this post:
viewtopic.php?f=34&t=31051#p190978

You can either set the Roku content meta-data parameter minBandwidth = 20 (or some other small value). Or implement a smil file on Wowza to work around their default 64 kbps settings.

--Kevin
0 Kudos
Highlighted
pinehead
Level 7

Re: Error: Missing or invalid PHY

Thanks, after i posted I cam across that wowza issue it has been fixed.

Thanks guys,
0 Kudos