Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku remote making a high pitch noise and drains batteries every few days.

The remote to my Roku Streaming Stick+ has been going through batteries very quickly. Today I tried to use the remote and the Roku device didn’t respond. I took the batteries out and waited 10 seconds and put them back into the remote. It started making a high pitch whining noise. I pulled the batteries again and got the same noise when I placed the batteries back into the remote. The noise finally stopped, but the remote isn’t working. I read where other people are also experiencing the same issues. There has to be a solution to this problem. I shouldn’t have to be replacing the batteries on a weekly basis.

0 Kudos
Retired Moderator

Re: Roku remote making a high pitch noise and drains batteries every few days.

Hi @Bgiess,

Thanks for posting in the Roku Community!

Can you please provide the serial number of your Roku device from Settings>System>About?

Once we have this information, I'll be able to pass it along to our Support team who can assist you further.

Best regards,

0 Kudos
Reel Rookie

Re: Roku remote making a high pitch noise and drains batteries every few days.

I do have mix of problems mentioned which includes problem mentioned in this thread as well in other threads. I have roku streaming stick +

for few months i am observing my new batteries lasts for just 2 weeks, i thought i bought it in deals so may be batteries are bad and i kept changing batteries. But after reading this thread i realize my roku remote too made high pitch noise many times which i ignored. This happened many times in last few months.

Then i bought new set of batteries ( more powerful last week) and expected them to last long, but this week out of nowhere roku remote stopped working. It does not pair at all. when i disconnect and reconnect batteries i see green led light blinking very fast which i read someh where mean its stuck in pairing mode. Also when i try to pair remote as new device i can not get my remote to go to pairing mode, no matter how long i keep pressing pair button on remote. 

I did go to system->remotes-> about and it shows battery level, firmware version etc of remote so i do believe its able to read the data but not working. 

Please note i have already gone through troubleshooting page and tried all the things mentioned. Any help will be appreciated. 

I have ordered HDMI extender cable and will see if that helps. 


0 Kudos