Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku Won't let me use my remote

I'm not sure what catagory I can put this one in so I'll put it here. My roku stick has been working perfectly fine for the past 3 days of me having it. This morning it worked perfectly fine but as soon as I got home, I noticed there was something wrong with my Roku. The purple light on it kept blinding and it wouldn't let me use the remote. The remote would work for a couple a seconds and then it would stop working, requiring me having to reset the Roku just to get it to work again. But when I did that, same thing keeps happening. When I tried to factory reset the Roku, the thing won't even let me navigate past the first screen. I tried pressing all the buttons on the remote but nothing happened. I tried to change the batteries on it but when I did that, it didn't work. I don't know whats wrong or what I should do but can someone please help me.

0 Kudos
Retired Moderator

Re: Roku Won't let me use my remote


Thanks for the post.

Can you please provide more information about the issue you are experiencing? What Roku model device are you using? When you state that the remote first works then stops working, what exactly are you doing with the remote? What are the exact steps to reproduce the issue?

With more detailed information, we will be able to assist you further.


Danny R.
Roku Community Moderator
0 Kudos