Remotes

Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Rebeccah
Channel Surfer

Roku Express 4K+ reboot/purple screen less than 24 hours after installation

I've never used a streaming device before, but just purchased a Roku Express 4K+ from Amazon.  I'm already having a problem one day after installing it.  I haven't yet tried the factory reset because I didn't know you had to hold the reset button for 30 seconds, just found that our while searching here.

I just received the Roku device from Amazon last night, and eagerly got it installed and running.  Today I went to try to find a movie for my father to watch, and in the middle of navigating with the remote control, the cursor stopped responding.  I panicked and tried randomly pressing buttons on the remote, nothing happened.  At some point during the random button presses, the Roku device apparently rebooted, as the bouncing Roku letters I had seen twice during the installation and setup process came on screen, followed by a purple screen.  There may have been a brief blink of a black screen in there, too, I'm not sure.

I don't know in what order I tried other things, but other things I tried included

- turning the TV off and on again with the Roku remote (did get the TV off but wasn't able to get it on again, I think I ended up using one of my other remotes to turn the TV back on again),

- opening the battery case and pressing the reset button,

- taking out and putting back in one of the batteries,

- changing the undated batteries that came with the device for dated ones I have in the house that shouldn't expire until 2030,

- changing the TV input from the Roku to the Cox cable, and then back to the Roku again,

- walking up to the TV and repeating all of the above numerous times at close range,

- unplugging the power from the Roku device and plugging it back in again.

One time I again got the bouncing Roku letters followed by purple screen.  All of the other times (including repeating whatever had gotten me bouncing letters again), nothing happened and the screen stayed purple.

I felt the Roku device to see if it is overheating, and it feels slightly warm, but nothing I would consider excessive.  Tepid.

Right now, Dad is watching cable TV while I research what is going on.

 

My setup:

I have an older Visio 1080p TV (I think model 390i-A1)

- Cable input on HDMI 2 input

- Sharp BluRay player on AV input

- Roku Express 4K+ on HDMI 3 input using the HDMI cable that came in the box with the device

- Power via the USB cable and charger that came in the box with the device

- Roku device stuck to the base of the TV pedestal using the removable sticky tape that came in the box with the device.

- Remote control using originally the two AAA batteries that came in the box with the device, and later two fresh Duracel AAA batteries.

- Distance of about 12 feet from the TV to the couch.

- Excellent WiFi connection strength to my home WiFi.

 

More details about last night's use of the device:

After successfully getting the device installed, and the system updated, I added all of the suggested channels to the home screen (some 67 channels, I believe).  I streamed a free movie with no hiccups whatsoever.  I added the channel for Roku Media Player and tested out viewing content from my PC (I had installed Universal Media Server on the PC, a Windows laptop, earlier in the day).  I found that any video clip from the PC of more than 30 seconds (subjective estimate) went to excessive buffering of just a few seconds at a time -- I attributed that to issues with configuring the Universal Media Server or too much stuff running on the PC, since streaming over the Internet had been so smooth.  I added another channel for the Roku Tips and Tricks and watched a few of those.  I tried adding Roku Originals channel, but it said it was wallpaper (which I have no idea what that means in the context of a device stuck to my TV), and hung trying to load, so I canceled out of it.  I changed the TV back to cable input before turning it off for the night.

This evening, when I turned the TV on and changed the input to Roku, everything seemed OK at first.  it was still on a screen for adding channels, and I used the back button to go back to the Home screen, and when I tried to navigate down the list on the Home screen with the arrow buttons is when the screen stopped responding to input from the remote control.

Have I got a defective device, do I have too many channels, or is there something else going on?

Labels (1)
Tags (2)
0 Kudos
1 REPLY 1
RokuDanny-R
Retired Moderator

Re: Roku Express 4K+ reboot/purple screen less than 24 hours after installation

@Rebeccah

Thanks for the post.

Can you please specify the current issue you are now experiencing with your Roku device? Are you simply not getting a response from the remote now, or are you still seeing the purple screen?

In addition, can you please provide the serial number of your Roku device from Settings>System>About? I'll be able to assist you further from there.

 

Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos