Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ROKU Stick remote stopped working

My ROKU streaming sticks+ stopped working.  I replaced the batteries for all 3 remotes.  I tried to re-pair all 3 devices.  The remotes will not pair.  I downloaded the ROKU app and was using that in the past, that no longer works.

I have used the 2 suggestions that are shown on the website.  I have 3 of these devices that use to work and now none of them are working.

I am at a loss at what to try next because now I am unable to use ROKU to see some of the services I have paid for.

0 Kudos
Community Streaming Expert

Re: ROKU Stick remote stopped working


If I'm reading things correctly, you have three separate Roku sticks that you've had for several months -- you didn't say the model number, so I'll assume they are either 3800 (Streaming Stick) or 3810 (Streaming Stick+) -- and all three have stopped communicating with the remotes.

Additionally, all three are unable to pair to the remotes.

Additionally, all three are not seen by the Roku app (not The Roku Channel app).

That all smacks of a network issue.

If any of my assumptions are incorrect, please correct them before proceeding, as all that follows may be useless otherwise.

@ckone wrote:

... I have used the 2 suggestions that are shown on the website. ...

You said "the two suggestions" but that is meaningless without a link to the suggestions. I have no idea what you've tried. So...

Unplug your Roku sticks, then reboot your network. If you have separate modem and router, turn them off, then turn on the modem, wait two minutes, then turn on the router, wait two minutes, then power up the Roku.

Many networks run both 2.4 GHz and 5 GHz bands. If your Roku is on one band, and your mobile device is on another band, they may not communicate, meaning your app won't see the Roku devices. If you are able to pick the band to which your mobile device connects, try the other one.

If you are an Xfinity Internet customer, check your wireless router settings to ensure the 2.4 GHz band is set to b/g/n and not g/n as some recent Comcast updates have changed those.

Others will likely have more (and maybe better) suggestions.

Roku Community Streaming Expert
Note: I am not a Roku employee.

If this post solves your problem please help others find this answer and click "Accept as Solution."

0 Kudos