Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Power Button is only remote button NOT working


Just bought another Roku for my living room tv.  I have the 4K+ with fancy remote and went through set up:

It identified my Onkyo and controls the volume and mute.

I had to let it try 4 codes on my Vizio before it turned off the music and accepted the TV.

The volume controls the Onkyo.  All other buttons work.

****The POWER button doesn't turn anything on or off. ****

I've read this forum and gone through the remote configuration repeatedly.  No workey.


Thank you,



0 Kudos
Community Streaming Expert

Re: Power Button is only remote button NOT working


Sometimes there are situations where TV manufacturers have similar code sets. In those situations, you could have a remote with one code set controlling some things, but not others. That may be what's happening with your situation.

First, you do not need to re-pair the device. That will accomplish nothing.

My suggestion is to do exactly what you did. I thought through the steps that I would normally suggest in this situation, and you've already done those. You tried additional code sets for that brand, so I don't need to tell you how to do that.

Try again, from the beginning. Ensure you didn't accidentally skip a code set along the way. Everything you have done to this point looks to be exactly what to do. I'm simply suggesting to do it again. Just take care to ensure nothing was skipped.

Roku Community Streaming Expert
Note: I am not a Roku employee.

If this post solves your problem please help others find this answer and click "Accept as Solution."

Roku Guru

Re: Power Button is only remote button NOT working

I’m not sure if the OP has tried lying.  ie: if saying – “yes the music stopped” doesn’t give you the codeset that fully works, you tell it the music did not stop so it tries later codes.

Reel Rookie

Re: Power Button is only remote button NOT working [SOLUTION]

I had to go into my Vizio settings and ENABLE the CEC Control.  It then showed my receiver, TV and ROKU as CEC enable devices.  The POWER button on the remote now turns all of them off and on.  YAY!

0 Kudos