Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

4660X Remote No Longer Syncs

Roku Model: Ultra 4660X

Software 10.0.0 build 4209-46

Remote model:  RC-AL4 (in battery cavity), though Remote & devices>Remotes>Gaming Remote>About says that it is Model RC193

I typically use my Harmony 700 remote to operate my Roku, but will use the remote that came with the device from time to time.  I tried using that remote yesterday and saw that it was not working. 

I replaced the batteries multiple times and followed the syncing procedure (hard reboot Roku, add batteries to remote once the Home screen appears, then press the paring button for 5 seconds, though the pairing light starts blinking green before I press the button).  The pairing light continues to blink green indefinitely after that.  Attempting to sync the remote when in Remotes & devices>Set up a new device mode also does not show any remote detection.  When I select "Set up remote for TV control", I see "Your Gaming Remote is asleep."

I know that my Roku attempted to update the firmware on my remote at least a month ago (displayed that message when using the device).  The About screen says that my remote was last used on July 9, which might be around the same time frame.

Is my remote bricked?  Is my Roku synced to the wrong remote model?  Any suggestions on how to fix this issue?

0 Kudos
Community Streaming Expert

Re: 4660X Remote No Longer Syncs


I have had a couple of problems pairing same remote with my Ultra 4660 at times.  When the pairing button doesn't seem to work to initialize, try the following...

1. Unplug the Roku Ultra.

2. Press the pairing button until flashes.  Remove one battery from remote.

3. Plug Roku back in to restart.

4. After Roku restarts, put battery back in. (I normally just place the remote on top of the Ultra).  The pairing circle should appear on screen shortly.  If not, just restart the Ultra again.

This has worked for me. Sometimes I can skip the Restarts.  I press the pairing button until it flashes, then remove a battery, then replace the battery and place near the Ultra and the pairing circle will appear. Others have suggested temporarily disconnecting the wifi (turning off the router) during the pairing process has worked for them when experiencing difficulty. 

FYI, my Ultra 4660x is showing a June 22 update with 10.0.0 build 4209-46. 

See if any of the above helps you and post back your results.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
Roku Guru

Re: 4660X Remote No Longer Syncs


If there was a problem updating your remote's firmware you'll need to get that addressed.

Message @RokuDanny-R  with your account/device information (login email, device ID/serial #, etc) and he should be able to help you further.

0 Kudos
Reel Rookie

Re: 4660X Remote No Longer Syncs


Thanks for the suggestions.  Unfortunately I am not seeing any success with those methods.  My Ultra is Internet connected by Ethernet, so I tried syncing with the Ethernet cable disconnected.  No remote syncing.  Shifting to a WiFI connection did not help either.

I'll send my account and Roku device info to the support staff later today.

0 Kudos