Learn how to reset a Roku remote, how a Roku remote works, or pair a new remote.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

3600X no response to any action on remote (RC80) after 10.0.0 4209-24 (new batteries and re-pairing)

My Roku updated to 10.0.0 on July 2. I got back from an overseas trip on July 10. I had taken the Roku with me. I have just now tried to use the Roku for the first time since returning. The stick is working fine when using the app to control it. However the remote will not do anything at all. I have followed all of the procedures. I have replaced the batteries with new ones. I have removed power, removed batteries, returned power, returned batteries, pressed button to re-pair remote. The remote appears to pair just fine. The led flashes, the screen says "Pairing remote...", led stops flashing, "Pairing remote..." message on screen goes away. However after all of this, the Roku does not respond to any button presses from the remote.

When I go to the info about the remote, it says the battery level and firmware version are both unknown, which suggests to me that the communication between the remote and the Roku is broken in some way.

I have tried a system restart. No difference.

I have tried more than one TV. No difference. (including TVs where it was previously working)

Since early July the Roku has not responded to a single button press from the remote other than the pairing button.

At this point I am not sure if the remote has actually paired but there is a firmware problem with the remote or if it has actually failed to pair but looks like it did pair. In any case, there seems to be no communication between the remote and the stick other than pairing.

What else is there that I can do?

As a note, I have seen numerous posts about problems with the remotes after an update and particularly 10.0.0. I have not seen any other post that closely resembles the problem that I am having. Numerous posts refer to volume, TV control or pairing issues, but none seem to have the total loss of all functionality, yet seem to pair just fine.

Roku Info:

    Model 3600X

    Software version 10.0.0 build 4209-24

Remote Info:

    Model RC80

    Battery level Unknown

    Firmware version Unknown


Just a note to Roku in general: 

The issues with remotes are very numerous. There seems to be a systematic problem. Maybe it is in the software update, maybe it is in the hardware design, or something else, but the timing coinciding with software updates is suspicious. Regardless, it does not look like Roku is actually doing enough to take care of the issue or to replace faulty devices. It does seem a shame that for what is otherwise a fine product, these issues are going to be driving away customers because of the widespread reports of customer experience on the internet, and cause what would be loyal customers to decide to go with a different solution. I know that for myself, if I am not able to have a satisfactory solution, I will probably not buy Roku again. And just to be clear, a satisfactory solution is not simply telling me to just buy a replacement remote on top of the money I already spent on the Roku originally. It is especially not satisfactory because I can buy an entire new streaming device for that price plus less than $10 more from Roku, Amazon or Google.  I do believe that for something I bought in late 2017/early 2018, the remote should not have died in only 3.5 years. If Roku believes that product lifespan of only 3.5 years is acceptable, then I definitely need to rethink who I am doing business with. I really hope that Roku will find a way to make this right.

Tags (1)
0 Kudos
Roku Guru

Re: 3600X no response to any action on remote (RC80) after 10.0.0 4209-24 (new batteries and re-pair


1)  In your modem/router/gateway configuration, change the 2.4Ghz channel to 1, 6, or 11 (or something other than what it is currently on) and/or the 5Ghz channel to 36 or 149 (or something different than what its currently at) - then restart the modem, then restart the Roku - try repairing at boot again

2) I recommend a Network connection reset (followed by a Factory reset if not successful), but you will lose your app connection to your Roku, and if they dont succeed in restoring a proper pairing, you wont be able to use your Roku (until you get that remote to pair, or get another remote to pair - a voice remote replacement is $20)

3)  You could always get a replacement remote for $20 Voice Remote (RCAL7R) available at Walmart/Best Buy/etc and attempt to pair it - if it doesnt pair you know its an issue with the 3600, and you can return it.   If it does you know its an issue with your original remote.

4) You can also just get a new Roku device - I recommend the Express 4K+ (not the 4K at Walmart) - look at   to see if you have one offered for $25 (otherwise they are $30-35).   You can also use the new remote to test your old 3600's pairing ability.

Again, you may not like/want the final 3 options, but if you want a fully usable Roku, you have to consider them.

You can also message @RokuDanny-R and he may be able to assist you further.

0 Kudos
Reel Rookie

Re: 3600X no response to any action on remote (RC80) after 10.0.0 4209-24 (new batteries and re-pair

I appreciate that you have given me something to work with. Your proposed action number 1 is new for me, I am not sure if it will make a difference or not. I will try that tomorrow. In fact I will try it in an area that has no wifi at all. That way if the issue is wifi interference or channel overlap, it would then work. and I can then worry about reconfiguring my network.

I will not even consider actions 3 or 4. I addressed that in my original post. Since I am unhappy with this, unless Roku can come up with a satisfactory solution or explanation (in other words have good customer service), then I don't want to be their customer.

Action 2 is not viable for now because I don't want to risk losing the entire functionality of the device, because I am not willing to get a new remote.

I will let you know how the thing goes.


0 Kudos