Remotes & Accessories

Help with Roku remotes and accessories, including pairing a remote, setting up TV power & volume control, using voice commands, power adapters, cables, headphones, and wireless speaker accessories.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 16

Re: Enhanced Remote - Strange Pairing Behaviour

Have you looked at any of the settings/info in the "Platform Secret Screen" (press Home 5x, then FF, Play/Pause, Rewind, Play/Pause, FF at about 2 button presses per second)? It might be interesting to see what channel it's using when you have it connected via a wired connection, although you may need an IR remote (which may be the solution to your troubles anyway) to access the secret screen. For what it's worth, both my Roku 3 and 4 that use a wired connection are using channel 165. If some 5GHz channels aren't available in the UK I would think the firmware wouldn't try to use them, so could it be that the unit thinks it's in the U.S.?

-JT
0 Kudos
Highlighted
Level 7

Re: Enhanced Remote - Strange Pairing Behaviour

Will try to borrow an IR remote - issue is I can only use my phone when its not working however it wont open the hidden menu
0 Kudos
Highlighted
Level 16

Re: Enhanced Remote - Strange Pairing Behaviour

Yeah, you kind of need a real remote; the phone app won't work. There is a way to do it via telnet if you're so inclined.
0 Kudos
Highlighted
Level 7

Re: Enhanced Remote - Strange Pairing Behaviour

If theres a way to do it via telnet that would be awesome
0 Kudos
Highlighted
Level 16

Re: Enhanced Remote - Strange Pairing Behaviour

telnet to your Roku's IP address port 8080.  You should get a prompt.  I'm not sure whether or not the Development Application Installer has to be enabled for it to respond on that port, so if you don't get a prompt or can't connect you may be out of luck since it takes another remote control key press combination to enable the installer.

At the prompt type:
press hhhhh>p<p>

That emulates the same sequence as I gave above.

-JT

Edit: I forgot, you can get your remote working when you have the Roku connected to your 2.4GHz network. If you need to enable the Developer Application Installer, connect to your 2.4GHz network and use the following remote key press combination: Home 5 times, Up twice, Right, Left, Right, Left, Right. Pretty much do it as fast as you can and ignore anything happening onscreen. You can leave the installer enabled; it doesn't hurt anything.
0 Kudos
Highlighted
Level 7

Re: Enhanced Remote - Strange Pairing Behaviour

Ok - telnetted in after installing the dev app and could control it fine. Rebooted and had same symptoms as before. Entering the secret menu shows;

Wireless Secret Screen;

AP:? (myhomenetworkssid)
Signal Strength: 0
Antenna 1: 29
Antenna 2: 22
Glitch/sec: jumps between 100-700

Channel: 44 RSSI: ---dBm noise: -91dBm SNR -- dB
Joins: 0 tries: 0 reconnect: 0 aps: 16 rate: MCS-15
TX: frames: 139 retries: 4 PER 2%
RX Frames: 137 glitches: 165kish (increasing) GPF: 1208
CC: XV6
Error: 0(0) Prior: (0(0)


Platform Secret Screen

Temperature: 54 C
IP: 192.168.21.13 via Ethernet
ozwpgan: 10.00.01.02.13-a (auto-ups) active: 1.         Pairing: off(auto)
(greyed out text) - Remote 0: RC10 (L1) F9:45 = 2.01.08.216 Batt 86% (2.88v) (asleep)



looks to me like it is switching to 5Ghz on channel 44 however I cannot see anything being broadcast on any wifi sniffers. Enabling Pairing mode didnt help either Smiley Sad
0 Kudos
Highlighted
Level 16

Re: Enhanced Remote - Strange Pairing Behaviour

It definitely sounds like there's something wrong with the 5GHz hardware. Have you tried changing your 5GHz AP's channel to 44 to see if the Roku can see it?
0 Kudos
Highlighted
Level 7

Re: Enhanced Remote - Strange Pairing Behaviour

Looks that way - will try channel 44. Anyone aware of a way to force it to use 2.4?
0 Kudos
Highlighted
Level 7

Re: Enhanced Remote - Strange Pairing Behaviour

Holy thread resurrection! Sorry been a while......

No Bueno on the channel 44 front - Still looking for a way to manually move it to 2.4g if anyone has any ideas?
0 Kudos
Highlighted
Level 20

Re: Enhanced Remote - Strange Pairing Behaviour

"a7x88" wrote:
Holy thread resurrection! Sorry been a while......

No Bueno on the channel 44 front - Still looking for a way to manually move it to 2.4g if anyone has any ideas?

Use a different SSID for 2.4  and 5 GHz radios and choose the 2.4 name for connection.  Smiley Very Happy
Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos