Remotes & Accessories

Help with Roku remotes and accessories, including pairing a remote, setting up TV power & volume control, using voice commands, power adapters, cables, headphones, and wireless speaker accessories.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mbj
Level 8

Cannot use HDMI or update remote software on Hisense Roku TV

We have a relatively new Hisense Roku TV.  Attempting to use any of the 3 HDMI ports, I am getting a message to update the remote software, "press OK."  When I do, nothing happens.  I cannot use the HDMI ports until this update is installed.  The TV software is up to date.  Please tell me how to update the remote software.

mbj
Tags (3)
0 Kudos
2 REPLIES 2\
StreamerUser
Community Streaming Expert

Re: Cannot use HDMI or update remote software on Hisense Roku TV

Hisense provides support for their TVs:  https://www.hisense-usa.com/support

However, you didnt provide your Roku TV model # or firmware version:  Settings/System/About

..or remote firmware version:  Settings/Remotes & devices/remotes/<remote name> (in use)/About

FYI "TV software is up to date" is meaningless since Roku implements model-specific builds and staggered rollouts.

1)  Check for updates:  Settings/System/System update/check now - try again

2) Restart your Roku TV:  Settings/System/Power/System restart/Restart - try again

3) Contact HiSense support: https://www.hisense-usa.com/support

StreamerUser
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
mbj
Level 8

Re: Cannot use HDMI or update remote software on Hisense Roku TV

Thank you for taking the time to reply.  The Hisense TV model is 43R6090G5 and the TV software is up to date.  It's the remote that's not, and I don't know how to determine the remote software version, not can I update it.  Just so you know, Hisense support says they provide support only for the hardware; Roku supports the software.  That's why I'm posting to this board.

mbj
0 Kudos