Remotes & Accessories

Help with Roku remotes and accessories, including pairing a remote, setting up TV power & volume control, using voice commands, power adapters, cables, headphones, and wireless speaker accessories.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Dkornf
Level 7

Beats headphones

I’ve been trying to use my Beats Studio 3 headphones with the Roku remote. While my regular Apple earbuds work fine with the remote, when I plug in the Beats I get mostly static. They work when plugged into my iPhone—no static. They work with the Roku app when plugged in on iPhone. Anyone know why the static with the remote? 

0 Kudos
2 Replies
RokuTannerD
Level 19

Re: Beats headphones

Thanks for the note here. A few questions/thoughts: 

- Have you tried replacing the batteries in your remote with a fresh, new set? 

- Have you tried a third set of headphones to see if you encounter any issue?

I'd recommend using the free Roku mobile app for private listening, if that option  works with your specific headphones. You might also try adjusting any audio quality or noise cancelling settings, or disabling  this functionality to test and see if this clears up the issue. Keep us posted from there and we can pass your feedback along to the team. 

 

Thanks,

Tanner

0 Kudos
bplesha1
Level 7

Re: Beats headphones

I just recently noticed I have the same issue with the user above.  I tried with the noise cancelling on and off, and got the same result both times.  I tried several other headphones which worked just fine, and tried several different audio cables with the Beats Studio 3 headphones, and got the same static each time.  I spoke with Apple care, who helped me ensure the firmware in the headphones were up to date, and they concluded that there was nothing else on their end that they could do unless I sent the headphones in to be examined.  However if someone else is having this issue, I'm guessing it's not a malfunction with my set of headphones.

The mobile app has never worked for me, and results in a different kind of static/jumpy sound.  But I always just used the remote and  have never encountered any issues until now.

0 Kudos