Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Katyaea
Level 8

Videos won’t load or run without rebooting router.

I have a Roku express. It was working fine for weeks then all of a sudden has stopped loading videos from some channels. It is hit or miss in which apps it will load. We’ve contacted specific apps (such as beachbody) for technical support and nothing they do seems to work. I can sometimes get it to work by rebooting the modem box but it will work for the first video but not others ones right after this. I can watch other apps with no issues. Just seem to be baffled by why it all of a sudden has stopped working like it did after I bought it. I’ve tried everything on every support list!

0 Kudos
3 Replies
makaiguy
Community Streaming Expert

Re: Videos won’t load or run without rebooting router.

Did your Roku recently upgrade to version 9.3 of its operating software? Find out via Settings > System > About. Many people are reporting similar problems since receiving 9.3.

Several people with varied problems after receiving the 9.3.0 update have reported success via the suggestions in the first paragaph of this post:
https://community.roku.com/t5/Remotes-Accessories/Roku-Streaming-Stick-remote-fails-after-new-system...
(After that, the post deals with a specific remote function that had to be re-enabled.)
I don't know if this will help with your particular situation, but it can't hurt to try.
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee.
0 Kudos
Katyaea
Level 8

Re: Videos won’t load or run without rebooting router.

I tried the ten minute reboot thing. Still nothing. 

0 Kudos
jsna1405
Level 7

Re: Videos won’t load or run without rebooting router.

I am unable to play videos in the beachbody on demand app.  I tried all of the suggested troubleshooting, only rebooting router worked but only for one video. 

0 Kudos