Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
jsmiddleton4
Level 7

Ultra still not holding 4K on my display

Since moving from FW 7 which worked perfectly for my older 4K display to version 8 even after passing the 4K/HDCP 2.2 test V8 FW would not hold the 4K capability.  Tests passes, about 30 seconds and the ROKU sets back to 1080P.

4K moves show UHD on VUDU. Playback with UHD badge, includes Atmos for those that have it.  Output from the ROKU is 1080P.  Tests done directly to TV, through AVR, new HDMI cables, etc.

Never held the 4K SDR output.

Apple TV does same sync/tests.  Passes.  Holds 4K.
Sony 4K bluray for K disks also works.

Put the ROKU in back for a TV that is not 4K as a result.

Been a couple of FW updates so thought I'd try again.

SAME result as before.  Passes 4K tests, ROKU doesn't hold the setting.  Falls back to 1080P on the 4K SDR display.   

Hoping 8.1 finally addresses what ROKU broke going from V7 to V8.  Not counting on it.  But will check it again to see.

Back to my Apple TV 4k for 4K streaming.  Multi channel 4K outweighs Atmos and 1080P.  Not like the Apple TV 4K sounds bad......
0 Kudos