Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

My 4800x Ultra updated last week to version 9.4.1 build 4212-C2 and since then I’ll start a Netflix or Disney show that’s 4K DolbyVision but the system stays in the default menu resolution of 1080p. I’ve gone in and out of multiple programs with the same result, the only way to resolve this is to back out and do a system restart. I can then go back in to the same app and program and everything works correctly. However, a couple hours later I’ll have the same issue and have to once again restart the system. This only because with the latest system update. Anyone else having this issue or have any solutions. Thanks. 

Labels (1)
0 Kudos
7 Replies
Level 14

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

FYI the default menu resolution of Rokus is whatever the max detected resolution is (Rokus always upscale all output to max res).

So if your TV is indicating a 1080p signal in the Roku menu UI, the Roku is either manually configured for 1080p, or 1080p is the max res detected by the Roku (Settings/Display type/Detected=?   ...).

If you are connecting through an AVR, try directly connecting it to your TV to see if its an EDID detection/AVR passthrough issue.

Also verify the HDMI port settings of the AVR/TV (make sure they are in Enhanced/Deep Color/etc mode).

 

Level 8

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

I am experiencing the exact same issue since the last update. I am passing my Roku Ultra though my AVR on its way to the TV. This was not happening before the update to the latest firmware. Before upgrading to the 4800X model, I had been using a 4670X model for almost a year, without issue. If Roku is reading this, please fix the firmware on the 4800X. The 4670X uses a different firmware.
0 Kudos
Level 7

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

Yup. Same issue and I’m running through an Arcam AVR and then through a balun. I too recently upgraded to the 4800x and had the older model for several years with non of these issues. At this point, I already have DV and Atmos through my appletv as well as HBO Plus and find I’m using the AppleTV more than the Roku because if it. I do hope Roku Support monitors these threads so we at least know someone is there for us. 

0 Kudos
Level 7

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

Thanks for your input. A couple of issues. As I said, this is an intermittent issue, as it only seems to happen when I’ve been watching other programs on Netflix or other apps, and it only seems to be happening when switching to 4K DV. I can go into a 4K HDR program with no issues so I would have to say it’s related to the DV handshake and how Roku is picking up that signal. The other issue is that I’m not able to connect directly as my AV rack is on another floor and I’m running across CAT6 via Atlona HDMI extenders. I’ve been running this tech for over 10 years and two houses so I know that’s not the issue as it’s only started since I upgraded to the 4800x. Thank you though for your input and insight. 

0 Kudos
Level 8

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

More informatoin. I switched back to my older 4670X, and the issue does not occur. This means it is specific to the 4800X.

0 Kudos
Level 7

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

I’m not surprised, I really do believe it’s related to the 4800x firmware. To be fair though, I haven’t had this happen on anything other than a 4K 60Hz DV program and the 4670x didn’t support DV at any resolution as far as I know. This leads me to believe there’s a bug in their EDID detection handshake that seems to resolve on a restart. I’ve never written that type of code but the fundamentals are the same when checking for state. As we’ve both said, I hope that someone will at least acknowledge our issues since I highly doubt we’re the only two users experiencing this bug. I’ll try to find a way to replicate the error so it’s a little easier to debug. 

0 Kudos
Level 8

Re: Ultra not switching to 4K DolbyVision since update 9.4.1 - build 4212-C2

New update. This behavior has stopped happening. I don't think there has been a firmware update, so I have no explanation. I'll keep an eye out, to see if the problem reoccurs though.

0 Kudos