Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
dizzbuster
Level 7

Ultra and Denon AVR-S930H problems

I am having problems with my new Denon AVR-S930H receiver and ROKU Ultra 4640x playing nice. I can not get any video out of the Roku when I go through the Denon receiver. My other devices (cable box, blu ray player) can display video with no issues it is only the Roku Ultra that has problems. I have tried various cables etc and alas no video. I can hook the Ultra directly to the TV and it works fine but no joy when I go through the receiver. Thoughts?
0 Kudos
4 Replies
Pompey
Level 7

Re: Ultra and Denon AVR-S930H problems

I have a new Denon AVR-X1400H which has HEOS on board but, I believe, has essentially the same logic control as yours.  You might want to check for defaults and then play with the following settings.  Some are mutually exclusive.
HDMI PassThrough
Pass Source
HDMI Control
4K Signal Format  (set to 10-bit?)

Make yourself a cup of coffee, or tea, sit down for a session and twiddle among these settings. I think you'll have success.

Also make sure you're using HDMI 2.0 , 2.1 cables.
"One great use of words is to hide our thoughts." Voltaire
"We are masters of the unsaid words, but slaves of those we let slip out." Winston Churchill
0 Kudos
dizzbuster
Level 7

Re: Ultra and Denon AVR-S930H problems

I got lucky. It ended up being a cable problem. I purchased a new cable and whala the problem was solved.
0 Kudos
Jbatt33
Level 7

Re: Ultra and Denon AVR-S930H problems

Do you happen to know which cable you got? I'm having a handshake issue with my deno 8500h and the only way to resolve is to plug and unplug the Roku to force the device to handshake with my receipt er again. After that, everything works as expected....
0 Kudos
Jbatt33
Level 7

Re: Ultra and Denon AVR-S930H problems

This is the issue I have, with the roku on and then turn on my AVR (Denon 8500H) I see the handshake to be successful. If I turn on the Vizio p55, I see the receiver doing another handshake, but this appears to fail. The resolution is to unplug and plugin the HDMI of my roku. I'm using a HDMI premium certified cable between the AVR and the Roku, but the one between the denon and the TV was supplied by Vizio. 

I'm going to replace both with the certified cables from mono price, passive, but only 6ft. I'll report back if I have any luck with these. If anyone has suggestions that would be get. I got the Ultra because I wanted the wired ethernet connect, but maybe that was a mistake... 
0 Kudos