Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pdet
Level 7

Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

Hello,

I'm on S/W 9.2.0:4131 for my Roku Ultra (4640 series) , and I cannot get my Onkyo to decode 5.1 audio over the HDMI port. The optical port decodes just fine. I tried "forcing" the audio in the Roku settings, to no avail. I tried several apps (Netflix, and Plex -- both decoded 5.1 using the optical port, but downmixed to 2.0 when using HD

This seems to have been a known bug back in an older version of the software, but per the thread in https://community.roku.com/t5/Playback-Issues-Audio-Video-Power/RESOLVED-No-more-5-1-Sound-Ultra-mod... it's purportedly resolved.

I can't say if my Roku ever successfully output 5.1 on the HDMI since my previous receiver had HDMI pass-thru problems, so I was using the optical cable. I was hopeful that I could use the HDMI inputs for audio and video with my new receiver.

Is this a setup problem?

Thanks

0 Kudos
1 Solution

Accepted Solutions
longstrider
Level 8

Re: Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

If you have volume leveling or night mode turned on, the audio output defaults to 2 channel. That setting can only be found while you are playing something (programs from Netflix, Amazon Prime, external drive  etc.) and pressing the * (asterisk, star - whatever you wish to call it). I had this happen to me and had a hard time figuring out what had gone wrong.  I had turned on volume leveling one night, and didn't use the Rokus (I have 3 4640R units boght when I found out they removed the SPDIF on newer models) for several days afterwards. I thought the September update had taken away my 5.1 , as it had BRICKED one of my units. After disabling the volume leveling, my 2 remaining units returned to sending 5.1 as before. Hope that helps. If not I have no other guesses, as that was the only audio problem I've had.

View solution in original post

4 Replies
longstrider
Level 8

Re: Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

If you have volume leveling or night mode turned on, the audio output defaults to 2 channel. That setting can only be found while you are playing something (programs from Netflix, Amazon Prime, external drive  etc.) and pressing the * (asterisk, star - whatever you wish to call it). I had this happen to me and had a hard time figuring out what had gone wrong.  I had turned on volume leveling one night, and didn't use the Rokus (I have 3 4640R units boght when I found out they removed the SPDIF on newer models) for several days afterwards. I thought the September update had taken away my 5.1 , as it had BRICKED one of my units. After disabling the volume leveling, my 2 remaining units returned to sending 5.1 as before. Hope that helps. If not I have no other guesses, as that was the only audio problem I've had.

View solution in original post

longstrider
Level 8

Re: Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

"bought"....not "boght"  Smiley Embarassed

0 Kudos
pdet
Level 7

Re: Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

Thanks @longstrider -- I had read that audio leveling or night mode could be a culprit, but all the posts said to look in options->audio for "night mode". I don't have that in my audio options. However, when I did what you suggested (hit * while streaming) it popped up, and it was indeed set to "leveling". I don't think I would have found that in a million years, so kudos!

0 Kudos
longstrider
Level 8

Re: Ultra (4640X) Cannot Decode 5.1 Audio on HDMI, but OK on Optical

Jump to solution

I'm glad you got it sorted. I hate to see the best Roku builds ever (4640R) go down.  Smiley Wink