Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
mjnoles1
Level 7

Ultra 4640 connected to optical audio. Center voice audio coming from wrong speaker

I recently bought the 4640 to connect to my 5.1 audio via digital optical cable, to cut the cord and use Hulu Live as my main source of television entertainment.

The problem when using Hulu Live is it is providing me stereo output, and when doing so, the voice audio that is supposed to come out of my Center Speaker is instead coming out of my Right Speaker only.

I know my system is connected correctly as when I used my cable company, voice audio came through my Center Speaker like it is supposed to.
0 Kudos
3 Replies
RokuDale
Level 8

Re: Ultra 4640 connected to optical audio. Center voice audio coming from wrong speaker

Do you have digital audio set to DD or something else?
0 Kudos
jeffrok
Level 11

Re: Ultra 4640 connected to optical audio. Center voice audio coming from wrong speaker

Just because one source worked fine with your receiver doesn't mean a different source will, especially if they were plugged into two completely different and settings-independent ports..

When you're watching Hulu Live in your Roku, what is displayed on the screen on your receiver? This will tell us if you're in a surround mode that's causing audio to play out of incorrect speakers. Hulu Live and Hulu Plus only play in stereo, so if you've got your receiver set to some kind of "simulated surround" mode, you may to just set it to auto or just stereo.

What is the model of the receiver, by the way?
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
mjnoles1
Level 7

Re: Ultra 4640 connected to optical audio. Center voice audio coming from wrong speaker

"RokuDale" wrote:
Do you have digital audio set to DD or something else?


For "HDMI and S/PDIF" I have it set to "(Dolby D, DTS)"

For "Audio mode" I have it set to "(Auto (Dolby D, DTS))"

Are these the correct settings or should I make a change?
0 Kudos