Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Lyn2
Level 7

Tv programs in Incorrect language on one channel

Tv programs in Spanish, while commercials are in English, on one channel only.

How do I revert back to English, when the language under Settings is already selected as “English?”

How did the language change by itself for one channel’s programs on all the Roku TV’s?

#Roku Express +
Also, is there any actual Roku support?

Tags (1)
0 Kudos
4 REPLIES 4\
makaiguy
Community Streaming Expert

Re: Tv programs in Incorrect language on one channel

Some channels observe the default settings you control in your Roku setup.  Some prefer to use their own controls and their own interface on how to find them - to try to maintain consistency between their apps on other devices,  I suspect.

What channel app are you having this problem with?  Maybe someone familiar with that channel can tell you how to find the appropriate setting.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.
0 Kudos
Lyn2
Level 7

Re: Tv programs in Incorrect language on one channel

It’s the CW.

0 Kudos
Lyn2
Level 7

Re: Tv programs in Incorrect language on one channel

Spanish also is the language available under the SAP, at bottom right, but it has “off” selected.  Nonetheless, I don’t see where to change it to English.

0 Kudos
jessicamoreno08
Level 7

Re: Tv programs in Incorrect language on one channel

Go to channel that is in Spanish and press the pg up button, you'll see AD, SAP, CC, click on SAP and you can change the language to English.  Good luck!

0 Kudos