Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
DavidY123
Level 8

Turn off CEC on Roku Ultra?

Is there a way to turn off CEC on the roku ultra? I've tried turning off the 1-touch setting but the roku is still fighting for control of my onkyo receiver. When I turn on my TV the receiver comes on, turns off and on a couple of times and then automatically switches to the roku even though I have the input set to the cable box. If I disconnect the roku everything works fine. 

15 REPLIES 15\
Tivoburkee
Community Streaming Expert

Re: Turn off CEC on Roku Ultra?

Are you powering the tv on with the roku remote? If so how about when you power the tv by the tv remote? 

Edmund
Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
DavidY123
Level 8

Re: Turn off CEC on Roku Ultra?

No I'm using the tv remote to power on.

0 Kudos
atc98092
Community Streaming Expert

Re: Turn off CEC on Roku Ultra?

In the Roku settings menu you'll find a setting for One-touch play. That is what enables CEC. Turn it off and CEC shouldn't do anything any longer. 

Oh wait, you already did that. To my knowledge that's the only CEC setting in the Roku. With my Sharp Roku TV, I do see one more CEC setting, labeled System Standby. But I don't know if all Roku devices have that setting.

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
DavidY123
Level 8

Re: Turn off CEC on Roku Ultra?

Yeah I already did that. I don't see any standby option. I'm wondering if anyone else has this problem or is it just me. 

0 Kudos
Guevon
Level 8

Re: Turn off CEC on Roku Ultra?

I too have the problem with my Onkyo receiver switching to my roku ultra input. I am about to unplug the ultra myself. Have you had any luck with your problem?

0 Kudos
DavidY123
Level 8

Re: Turn off CEC on Roku Ultra?

Someone suggested this device to bypass the CEC signals on the HDMI cable. 

https://www.amazon.com/dp/B00DL48KVI?ref=ppx_pop_mob_ap_shar

It did the job for me. Hope that helps. 

0 Kudos
atc98092
Community Streaming Expert

Re: Turn off CEC on Roku Ultra?

CEC has always worked perfectly for me. The TV brands vary (Samsung, LG, Vizio), but for my players running through an AVR it's always Yamaha. 

But CEC is like many other "standards", in that companies doesn't always follow the requirements exactly. And that's unfortunate, because when CEC does what it's supposed to, it's a great tool. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
DavidY123
Level 8

Re: Turn off CEC on Roku Ultra?

Yeah it seems to work fine between my Samsung TV and my Denon receiver (I returned the Onkyo piece of junk) but the Roku seemed to keep muscling in and interfering. That's where I placed the device to cut out the CEC signals from the Roku. 

0 Kudos
dcaler
Level 7

Re: Turn off CEC on Roku Ultra?

any solution yet?

0 Kudos