Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

TCL TV Requiring Daily Restart to Function

MY TCL 6-Series is two months old. It's running the latest software 9.4 build 4200-88. Network signal strength is excellent and my router/service consistently speed-tests at 29mbs. After a couple of weeks of ownership, I noticed buffering issues. These were not limited to a single channel - it could be Netflix, YouTube, etc. And this is not limited to some intensive 4k movie. A simply low-res YouTube video would choke. I would jump over to my AppleTV streaming box and try the same channels/videos and they worked perfectly. To solve the problem on my TCL, I would go to Settings->System->Power->System Restart. Problem solved! Then it reappeared 2 weeks later. Then a week later. Now every morning I turn the TV on and it chugs and buffers. I have to start the day with a system restart. A second problem that surfaced last week is that if you are watching any show in Dolby, should you skip ahead or backward, the audio feed to my home theater reverts to stereo. The only way to get the surround sound back is to exit the show and hit resume. Pausing it is okay. But it means I can never back a movie up to hear what I missed or the Dolby sound will switch to stereo. Again, I can bop over to my AppleTV box and not experience this audio problem. All my problems are through the Roku OS in the TCL TV. It's almost as if the internal memory is filling up and not clearing and the system just grinds itself to a halt. At this point, the SMART TV aspect of the set is becoming useless. My AppleTV box is not 4k, and I shouldn't have to use/buy an alternate 4k streaming system when my TV has it built-in. I'm considering returning the TV unless someone can think of something else to do/check/try.

0 Kudos
3 Replies
Level 7

Re: TCL TV Requiring Daily Restart to Function

I don't think this is a buffer/network issue because even the apps are slow to open. So, opening YouTube takes forever. The individual thumbnails are super slow to load. If I jump to Roku Live TV channel it takes a long time for the show to come up. If I hit the left arrow to pull up the Channel Guide, it will list "No Data Available" for all channels for 10-15 seconds before the channel listings slowly appear. If I do a TV Restart, it all works quickly. But, as I said, I now have to do that Restart every morning in order for the TV to function for the day.

0 Kudos

Re: TCL TV Requiring Daily Restart to Function

Mine is around a year old and has just started requiring almost daily system restarts.  If yours is a recent buy, return it.  I am looking for my paperwork to see what the warranty is.

0 Kudos

Re: TCL TV Requiring Daily Restart to Function

I meant to say mine isn't slow to load, but I get a blue pixilated screen when I attempt to stream a channel  The channel loads normally until I make a selection of what to watch then the screen goes to a strange blue thing.

0 Kudos