Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Dpayne1022
Level 7

Static noise ... crack, popping

Jump to solution
Just bought the Ultra. Hooked it up today and sounded fine. Immediatly a firmware update was forced. Upon reboot, a popping and crackling began. Now when I stream services it is all garbled static. I've changed every setting, cords, ports, even down to removing all other close proximity devices. Factory reset....did that 3 times. Still nothing. Anyone had this issue and know how to fix it?
1 Solution

Accepted Solutions
Geoffgreen
Level 7

Re: Static noise ... crack, popping

Jump to solution

Hi All,

I had this problem and I believe I have the fix.  The stem of the issue is that Roku includes a fairly inferior HDMI cable with their outstanding product that we all love.  The HDMI cable that they include with all of their units is of low quality, it has little to no shielding from static electricity and other sound degrading interference.  I tried all the restart and unplug tricks and they did not work for me...  Then I went to Amazon and spent $12.99 on the Amazon Choice HDMI cable which includes shielding and an "earth wire" and problem solved.  

Get a good, quality HDMI cable and the crackling and popping will be gone.

Good Luck - G

View solution in original post

0 Kudos
63 Replies
Tim66
Level 7

Re: Static noise ... crack, popping

Jump to solution

I too have the same problem on a new Roku Ultra. Apparently this is a common issue on various model Rokus as I see it all over the internet. Unfortunately I don't see any solutions being presented. I'm about to return this and exchange for some other streaming device. Roku apparently has no interest in fixing the issue.

I'll try to contact Roku support and see if I can get them to do something.

N2Gems
Level 7

Re: Static noise ... crack, popping

Jump to solution

I was about to either call Roku to see if they would honor their warranty, or just go buy a new one and decided to go old school. I gave it a few open handed "smacks" and voila! No more cracking and popping sounds. Not sure if it's a longterm fix, but it's good for now. 

Caledonensis
Level 7

Re: Static noise ... crack, popping

Jump to solution

I am currently having the same problem, but it comes and goes.   It worked flawlessly for a month or so.  But now, the static and popping.   I am using a near new HDMI cable from Roku Ultra to Yamaha sound system to TV.  If I unplug the Roku and shut off the sound system and  disconnect and reconnect the HDMI cable, then reconnect everything and power back up, that often fixes it for a while, but next day I had same problem again.  Any word or answer?

Caledonensis
Level 7

Re: Static noise ... crack, popping

Jump to solution

Also, the Yamaha is only a few months old.  Its a Yamaha RX-V685 7.2-Channel AV Receiver with MusicCast.

N2Gems
Level 7

Re: Static noise ... crack, popping

Jump to solution

It's been a few days and the crackling and popping has not returned. 

bam817
Level 7

Re: Static noise ... crack, popping

Jump to solution

I also gave it a good smack. Re did the cables, and for now, the static is gone. Will see what happens tomorrow. Thanks for the tip. 

TA11dude
Level 8

Re: Static noise ... crack, popping

Jump to solution

I’m having the same issue. A reboot fixes the issue, temporarily, including a soft reboot from the menu. Then the issue comes back in a day or so. So I suspect the “wack” you did only worked because you powered it off. I suspect a software issue because it’s fixed by reboot. Roku, any fix??? I own a Roku 4 and 3, and have never seen the issue there, only on Ultra.

daemonR00t
Level 7

Re: Static noise ... crack, popping

Jump to solution

Great so I am not alone then Smiley Sad

TA11dude
Level 8

Re: Static noise ... crack, popping

Jump to solution

I might have found a fix: go to settings -> audio -> audio mode and change from "auto" to "stereo", assuming you don't have a system with more than 2 speakers. After doing this, the issue has not returned yet after a number of days.

If this is really a fix, it's obviously a software bug with the automatic audio mode detection.