Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Marshah327
Level 7

Sound but no streaming of video

I have the Roku player device attached to my tv and everything I watch is streaming. I watched basically all day yesterday and then one series ended and I went to watch the next one and when I clicked play, my screen turned a sold color with faint vertical lines and I could hear the show, but no picture.  I then tried a different show and same thing.  I exited to home and tried my cable tv app and it would show the channels but when I selected one same thing.  So basically any app I clicked on would load like it was going to play normally with icon up and sound but then just sound only and solid screen.  Can anyone help?

0 Kudos
10 Replies
Jana
Level 7

Re: Sound but no streaming of video

I’m having the same issue. I have Comcast cable/internet. When I try to watch Hulu or Netflix all the launch items come up etc, but once I click to watch a show I can hear the audio, but no picture. What’s going on? 

0 Kudos
kaelturpen
Level 7

Re: Sound but no streaming of video

Same here. Has anyone fixed this yet? I can see thumbnails and previews in all apps, but even the "Roku Tips & Tricks" app could not show me any video. But the sound works great.

0 Kudos
MaxxWall
Level 7

Re: Sound but no streaming of video

Any fix here yet? ROKU why no response to hundreds of questions??? We watched it no problems yesterday now a cream color screened with sound but no picture.

0 Kudos
Andy123
Level 7

Re: Sound but no streaming of video

I am also having this issue. The user interface menus and sound are working as normal. But when it goes to stream a video (whether YouTube, Netflix, Disney+, etc.) only the audio works, and the screen goes black. 

0 Kudos
Andy123
Level 7

Re: Sound but no streaming of video

Ok found another thread. 
go to settings > system > restart. 
that worked for us. 

LMN
Level 7

Re: Sound but no streaming of video

Thank you for sharing, that worked and saved me a load of troubleshooting!

TechDude
Level 7

Re: Sound but no streaming of video

I get a purple screen with audio and no video.  I figured out the reset is only a temporary fix to get the video back.  It happens once the box is unused for a while.  We have to reset the box at least twice a day.  I have the Roku Ultra and its less than a week old.  It'd definitely a bug.  

Tags (2)
0 Kudos
eichcj
Level 8

Re: Sound but no streaming of video

Same issue here.  I have an HDMI switch for a PC and Roku Ultra (3 days old) to share HDMI 2 port on my TV.  HDMI 1 is used for satellite STB/DVR.  Switching between HDMI 1 & 2 on the TV or PC & Roku source for HDMI 2 'supposedly' causes HDCP connection issues that produce purple screen without the "HDCP error message".  Thumbnails in the Roku channel screen and video thumbs within the channels (Youtube, History, Prime Video) are all visible, however, playback produces the purple background with only audio.  Restarting the Roku, while selected for viewing, fixes the issue and normal video viewing is restored.  Have tried the Roku direct to HDMI 2 connection remedy but still have the issue when switching HDMI inputs on TV.  Previously worked fine with the Roku 3.  Roku needs to fix the HDCP bug.

0 Kudos
TechDude
Level 7

Re: Sound but no streaming of video

I am fairly sure that my issue is the TV itself.  It was a cheap Flat panel RCA 48" but its quite old and not updatable.  I am not using a HDMI splitter or anything else.  The Roku is plugged into HDMI #1.  

In addition to the 'sound but no video' issue, I can't get the Roku remote to control the power button.  However, the volume control does work.  The RCA TV doesn't meet the minimum specs for Roku.  I think my solution is going to be a new TV.  I am planning on doing that for Christmas.

0 Kudos