Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Rocket_J_Squirr
Level 8

SOLVED: Roku Premiere loses HDMI between shows

Jump to solution

I have a newish Roku Premiere 3920R connected to my Marantz AV8805 preamp, which feeds my Sony VPL-VW600ES 4K projector.

I'm having a most annoying problem. The Premiere will play one show just fine. But at the end of the show, the screen goes black, the sound cuts off, and the projector shows the "No HDMI" indicator. I must toggle the preamp to a different input and back again to force a new HDMI handshake. Then I can see that the next episode of whatever series I'd been watching is already playing on the Premiere, and I've missed the first 30 seconds waiting for a handshake.

I don't think the problem is switching from content to menu. What I see is the show's closing credits and the box in the lower right corner telling me the next episode will start in 5..4..3..2..1 and then the screen goes black and the sound goes off. The Roku is not going to menu, it's going to the next episode.

This happens almost every time with all content. Sometimes power cycling the Premiere helps for a while, but then it goes back to its bad habits. I am using the HDMI cable that came with the Premiere. I think my downstream cable from preamp to projector is fine because I don't have any trouble with my Sony UBP-X800 4K disc player.

Is this perhaps a symptom of lacking HDCP 2.2? I don't know whether my equipment supports that version. In any case, I'd appreciate ideas on how to solve this problem.

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
Rocket_J_Squirr
Level 8

Re: Roku Premiere loses HDMI between shows

Jump to solution

The culprit was the Frame Rate Matching setting. I was unaware of its existence, but it was enabled by default. Disabling it solved my HDMI lossage problem.

View solution in original post

0 Kudos
2 Replies
Rocket_J_Squirr
Level 8

Re: Roku Premiere loses HDMI between shows

Jump to solution

The culprit was the Frame Rate Matching setting. I was unaware of its existence, but it was enabled by default. Disabling it solved my HDMI lossage problem.

View solution in original post

0 Kudos
atc98092
Level 21

Re: Roku Premiere loses HDMI between shows

Jump to solution

Yeah, frame rate matching can be problematic on Roku players. Not sure why, but they haven't gotten it dialed in yet. 

Any for anyone else, that setting is only on the Roku 4K players, so not on the Express.

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos