Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
droopdog7
Level 8

Roku ultra audio settings

Just set up a roku ultra and and bugged by how the audio is behaving. I have a surround system and when the audio on the roku is set to Auto, every show says Atmos.  When I set the roku audio option to Auto Passthrough, all content shows at Dolby digital plus.  Is there an option that will show what audio is actually correct?

0 Kudos
3 REPLIES 3\
StreamerUser
Level 20

Re: Roku ultra audio settings

"Auto passthrough" is the best option - it will show DD+ for most content, even Atmos (streaming services use DD+/Atmos) and for DD-only legacy systems, will transcode DD+ to DD.

"Auto detect" is actually "Auto transcode" - it will transcode all non-DTS output to the highest supported Dolby Audio level of the connected device (if thats PCM MAT 2.0/Atmos, then thats what everything is output at).

Try restarting all devices in the HDMI chain (Roku/TV/AVR) after making the change to "Auto passthrough".

0 Kudos
droopdog7
Level 8

Re: Roku ultra audio settings

@StreamerUser Appreciate the response.  Are you saying that I can’t play atmos unless I force atmos on everything?  That I have to go back and forth maybe?  That’s seems kinda ridiculous no?

And not sure why I might need to reset devices, unless, that will make true passthrough work correctly?

0 Kudos
StreamerUser
Level 20

Re: Roku ultra audio settings

Not saying that at all - you may want to re-read my previous post.

The suggestion to restart (or unplug/replug) is to reset the HDMI chain (EDID issues abound) since you were stating you were getting everything as DD+ in Auto passthrough mode (you shouldnt be).

I also want make clear the Atmos you get from streaming services is DD+/Atmos (so it should be detected as DD+ by your AVR/soundbar, with Atmos).  You should be getting PCM 2.0 as PCM 2.0, DD as DD, etc.

Put it in Auto passthrough and do some tests:  NetFlix/Prime/Hulu/Disney+ output 5.1/Atmos in DD+, so all those should come through as DD+.

The Roku Channel and Apple TV output all (non-Atmos) 5.1 as DD.  Paramount+ defaults to PCM 2.0, but can be configured for DD+ or DD output using Options (*) during playback.

If your AVR/Soundbar shows DD+ using Auto passthrough for all content (2.0/5.1) on all the apps/services I mentioned, then the most likely reason is that your AVR/soundbar (or whatever the Ultra is connected to) is applying some surround processing/upmixing, or alternately there is an EDID issue such that your AVR/soundbar/device is only advertising DD+ capabilities.

Highlight Settings/Audio/HDMI/Auto passthrough to see what codecs/formats the Roku detects your AVR/Soundbar/TV as supporting.