Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
Winterfitz
Level 7

Roku started set up then went blank

I was almost done setting up my roku express when the screen went blank. Ive tried changing TVs, cables and different inputs between 3 TVs. The power light is indicating its getting propper power but there is 0 response from the ubit. Ive even tried holding the reset button and that didnt do anything.
0 Kudos
8 Replies
atc98092
Level 16

Re: Roku started set up then went blank

When using the reset button, you have to hold it a minimum of 30 seconds, or even longer. You may have, but since you didn't mention it I wanted to point that out. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Winterfitz
Level 7

Re: Roku started set up then went blank

Hey thanks for the advice, i went back and made sure i held it for 30 sec and then 60 sec and nothing happened.  
0 Kudos
Basil
Level 10

Re: Roku started set up then went blank

"Winterfitz" wrote:
Hey thanks for the advice, i went back and made sure i held it for 30 sec and then 60 sec and nothing happened.  

Nothing happening seems to indicate that you didn't hold the button properly. Because something should definitely happen. It should reboot, at a minimum. You should get the boot screen. Since "nothing happened," that indicates a huge issue.

Try uplugging the device. After several seconds, plug it in again. Do you get the bootup screen?

Not even seeing it reboot indicates there is no signal getting from the Roku to the TV. You seem to have done a thorough job in using multiple cables, inputs, and TVs. Since you're getting a power light, that indicates the Roku is getting some power, at least.

Oh, one other thing. Are you powering from the included power supply, or are you connecting to a USB port on the TV? If the latter, try the former instead.
Basil
https://www.basilsblog.com/
Roku Ultra (4660)
Apple TV (5th gen), TiVo

Previous:
Roku boxes from every generation.
Apple TV (2nd, 3rd, 4th gen)
0 Kudos
killaflexx
Level 7

Re: Roku started set up then went blank

how are you connected to the TV? make sure the input you chose is the correct one.i am just going over possible issues. step by step i probably can help you get back on track. Start off unpluggin everyhting turning off tv. try HDMI cable or a different input let me know if that helped
0 Kudos
Winterfitz
Level 7

Re: Roku started set up then went blank

@Basil,

Yes i thought i might be messing up the reset button since depending what you use you can slip off so I found a pen that just fits in the outer hole and I can feel the button depress.  

But, you're right from what I can tell there is no signal at all coming from the Roku.  I even left it unplugged over night so hopefully any remaining power might discharge and even then I get nothing.   No boot up screen no sounds, I've even tried giggling the cable a little thinking maybe I somehow loosened a contact.  I am using the provided power supply.  And I've switched between a surge protector and going directly to the wall.  The light i'm getting is white, vs the "red" which the manual says indicates not enough power.  

@killaflexx yes i've double checked the input to make sure i'm not looking at the wrong one.  [/color]
0 Kudos
Basil
Level 10

Re: Roku started set up then went blank

I'm going with defective device. Return or exchange it.
Basil
https://www.basilsblog.com/
Roku Ultra (4660)
Apple TV (5th gen), TiVo

Previous:
Roku boxes from every generation.
Apple TV (2nd, 3rd, 4th gen)
0 Kudos
Winterfitz
Level 7

Re: Roku started set up then went blank

have you heard of this happening?  My friend's went out too.  He had it for about a month, and told me how great it was and I went ahead and bought one.  I called him yesterday and he said he was having the same problem, but he got a streaming stick i think.  
0 Kudos
Basil
Level 10

Re: Roku started set up then went blank

No, that is not a common thing. My family has purchased many Roku devices over the years and we've had very good success with them all. I've only used one Express, of a family friend, but it's been a great little device for her. My Roku Stick performs well.

I'd still return the Roku Express to the store, or exchange it for another, and see what happens.
Basil
https://www.basilsblog.com/
Roku Ultra (4660)
Apple TV (5th gen), TiVo

Previous:
Roku boxes from every generation.
Apple TV (2nd, 3rd, 4th gen)
0 Kudos