Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Philt56
Level 7

Roku powers off connected to Oppo

I have my Roku Ultra 2020 connected to Oppo 203 hdmi input. I do this since my receiver doesn’t support 4k pass thru and if I connect to my LGE6 tv, I don’t get surround sound back to my receiver using optical out. ARC doesn’t work. 

Everything was working fine but lately if I turn on the Oppo and switch to its hdmi input, my tv doesn’t see a signal. I have to unplug the Roku and plug back in and then we are fine. Why is the Roku turning off? I assume because the Oppo has powered off? The Roku itself has power always on.

is there a way to keep the Roku active without keeping the Oppo powered on? The Oppo is on standby. 

0 Kudos
3 REPLIES 3\
StreamerUser
Level 20

Re: Roku powers off connected to Oppo

That TV ARC/Optical & potential transcoding issue sounds odd (you should spend some time working that out - sounds like a Simplink/Audio settings issue - if its just with the 4800 that you experience it you may want to change Settings/Audio/HDMI=Dolby Digital when you connect it to the TV).

Are you sure the Roku is powered off?  Sounds more like a loss of HDMI sync (HDMI handshaking issue).

Try manually configuring Settings/Display type=4K DV TV (or 4K HDR TV or 4K TV, if the 30/60Hz issue applies).

0 Kudos
Philt56
Level 7

Re: Roku powers off connected to Oppo

4800?  The tv only supports DV at 1080p. It supports 4k hdr. At least when streaming  does fine with UHD discs on the Oppo  has to do with 60 hz streaming  

yes, I use hdmi bypass as the input for the Oppo

 

so yes, probably losing hdmi connection to the Oppo and I have to power cycle the Roku Ro get it back. But why? Would it do the same thing connected to a receiver or tv?

0 Kudos
StreamerUser
Level 20

Re: Roku powers off connected to Oppo

You stated you had a "Roku Ultra 2020" - that's a model 4800.

You should check your model # and firmware version:  Settings/System/About

Your E6 should be able to pass DD via ARC/Optical from both internal apps and connected devices without issue - if you cant there is a configuration issue in the TV's Simplink/Audio settings or the AVRs CEC/ARC settings, or both (or a bad/unsupported cable).

Not all HDMI devices/ports are equal, and not all HDMI handshaking sequence results are the same, so you could very well get different behavior with the Roku connected directly to a TV/AVR.

Again, try manually configuring the display type.

0 Kudos