Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pizzasloths
Level 7

Roku express buffering on multiple channels

For the past month or so, our roku runs extremely slowly or buffers on multiple channels - especially Netflix and Paramount+. We tried resetting the roku multiple times and it did not fix the issue. I know it can’t be the network/internet connection because we’ve resorted to using the TV’s built-in Samsung smart hub to stream instead and it runs just fine, no buffering whatsoever. I couldn’t find anything helpful in other threads or in the support guides. Is it possibly just an issue with the device itself?

0 Kudos
4 REPLIES 4\
atc98092
Community Streaming Expert

Re: Roku express buffering on multiple channels

Buffering is almost always a network issue. The fact one device works fine isn't a reliable indicator.

The first thing to check is the channel your wireless router is using for the 2.4 GHz radio (might be the only radio it has if it's not a dual band unit). There are 11 channels that are supported on Roku devices, but because of the way channels are spaced the best to use are 1, 6 or 11. Your router is likely set to auto-assign the channel, so first try manually assigning one of those three channels.

Also, your router might be configured to use all available protocols on the band, and sometimes that causes issues with connected devices. Unless you have a really old wireless device, you likely only need 802.11n as the protocol used. Check the settings and see if there's a box labeled "Legacy" or something like that, and turn it off. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
makaiguy
Community Streaming Expert

Re: Roku express buffering on multiple channels

It may not be a problem with your internet or local network, but with your Roku's connection to it.

Here's what has worked for me.

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • Restart the Roku to clear its memory via Settings > System > System restart (for a Roku TV it's Settings > System > Power > System restart). Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
Note: I am not a Roku employee, just a user like you.

Roku Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Roku Streaming Stick 3600
0 Kudos
pizzasloths
Level 7

Re: Roku express buffering on multiple channels

I’m on channel 1, so that seems to be okay. 
Unfortunately I don’t know much about how to deal with the protocols you mentioned. I have the newest version of a Verizon FiOS router, just got it in Sept 2020. There are some router settings I can update on their app but I don’t see anything about protocols.

The only thing I have thought of that might be affecting this is that I had to disable our self-organizing network in order to connect and use our smart laundry machine. The roku started having connectivity problems around that time, but I feel like it should still work regardless if it’s connected properly to our WiFi? Confusingly even though I’ve disabled the SON we still only have one WiFi network name coming up (rather than separate 2.4 and 5 GHz networks) so even more reason why I thought the roku should be fine. 

0 Kudos
atc98092
Community Streaming Expert

Re: Roku express buffering on multiple channels

The Roku you have doesn’t support 5Ghz, so you’re only seeing the 2.4 GHz radio.

they might use a different phrase for the protocols. I’m away from home, so can’t look up exactly how mine are labeled. But you might find a setting that lists 802.11 with a lot of different letters on the end, such as b/g/n. You most likely only need N enabled. 

Since you’re on channel 1 now, I’d try the other two in case you’re experiencing interference. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos