Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vita
Level 7

Roku device bricked after disabling Guest Mode via account settings

I just found one of my Roku Streaming Stick devices (it says SKU 3600## on a sticker with barcodes in the box, where ## is a country code). It had been put away for a very long time.

Anyway, I set it up on a TV, and updated it. After the update, I noticed AirPlay showed up in the settings and shortly after Guest Mode was enabled--I had enabled it from my account settings but only after the update I assumed it gained the functionality of remotely setting settings on it.

I failed several times trying to disable Guest Mode directly on the device because I didn't remember the passcode so a set up a new one in the account and disabled Guest Mode for this device, which unlike the rest on the list now it had a status that wasn't years old.

So far so good. Then, when the Roku device received the new settings it started doing its thing culminating on a restart, I thought, except it never came back. The device outputs no video and I noticed the LED flashes in white twice every second or so after the power up sequence--or whatever is happening when it's solid white when first power is applied.

I tried it in other HDMI ports, same thing. I went from TV to TV all HDMI ports on the TVs and AV receivers, always no signal, constant 2x white LED flash. To be clearer; the blinking is not random at all, it appears timed, like and indication of something. (longoff-white-white)

The device had been in storage and I know it should be working, I just witnessed it. Thanks to the account page I know for certain when the device was purchased and, though it's been a while I have Apple TV boxes bought on the same year that are still working--these took whatever workload Roku might've had at the very least saving it from heat damage from normal operation...not that it should be a concern, anyway. It makes no sense for it to brick itself, literally just taking it out of the box and used as instructed. It wasn't used more than a month, maybe month and a half when first purchased either--it still has the new plastic smell.

I've like a million questions, but the must-know-first is/are: what does the blinking mean? How can I restore the device to a working condition? Does this happen often? Is this intentional by Roku to push users into new hardware? I hope it was a really bad coincidence because I actually want to get a few more if not true, I like the headphones-in-remote feature.

Labels (1)
0 Kudos
1 REPLY 1\
renojim
Community Streaming Expert

Re: Roku device bricked after disabling Guest Mode via account settings

Roku has never told us what the blinking lights mean or if there's different sequences, but it most likely means it's not connected to your Wi-Fi.  There's a reset button on one of the edges.  With everything connected press and hold that button for no less than 30 seconds.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos