Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
piggyback
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

"piggyback" wrote:
Looking for help with HDCP error out of the blue...

I got a Roku Premiere+. Plugged it into my Marantz 7007 receiver. Receiver uses a Sony VPL-HW30AES projector display.
I am using the Roku at the moment for Amazon only. All worked well for 3 weeks. All the sudden I am getting HDCP unauthorized.. pink screen... Nothing changed with my setup. I tried power cycling, unplugging HDMI cable and so on with no success.

Any ideas?

I decided to truly power off all devices (unplugging). Afterwards the Roku worked again. It looks like Roku has clearly a HDCP handshake protocol error. My other HDCP dependent devices work just fine (HTPC, BluRay player, cable box,...). BTW. Just unplugging power and HDMI cable from Roku did not work.
0 Kudos
pobp912
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

my Roku ultra has gotten worse with the hdcp error.i will advocate to everyone don't purchase these until they fix it.i tell ewveryone o know this is a problem they know but refuse to fix. shame on roku
0 Kudos
mintakax
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

Yep, my ultra has occasional problems with this. Its a pain, but a reboot usually fixes things for me.
0 Kudos
zetto
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

at least 2 or 3 times a day I have to reboot Roku Ultra because of the HDCP issue.

I used two different HDMI cables I had but it didn't help.  So I purchased a HDMI cable at Amazon that is supposed to be the latest generation of HDMI cable... didn't help one bit.

I would NOT recommend purchase of Roku for high def 4k ultra tv's
0 Kudos
atc98092
Level 16

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

"zetto" wrote:
at least 2 or 3 times a day I have to reboot Roku Ultra because of the HDCP issue.

I used two different HDMI cables I had but it didn't help.  So I purchased a HDMI cable at Amazon that is supposed to be the latest generation of HDMI cable... didn't help one bit.

I would NOT recommend purchase of Roku for high def 4k ultra tv's

Is your Ultra plugged into an AVR, or directly into the TV? I ask because I have no issues with my (2016) Ultra, which uses Amazon Basics HDMI cables between the Roku and Yamaha and again between the Yamaha and Samsung. No idea if having the Yamaha in the string is helping or not. You also need to make sure your TV (and AVR is used) has the HDMI ports set to support 4K 60Hz. With Samsung, it's called UHD Color. Other brands have different labels. My Yamaha has to be set to Mode 1 in a hidden boot menu.
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Dch112
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

I just purchased a Roku Express + yesterday. I was watching a YouTube video within a few minutes it suddenly stop playing and appeared on the screen HDCP unauthorized purple screen. I went to the suggested website. I do not understand this at all. None of my equipment supports 4K including the Roku Express+. One of the suggested solutions on the website said to replace the HDMI cable. I was using the supplied HDMI cable included in the box with the Roku Express. I pulled a cable from a DVD player and tried it on the Roku Express, that did seem to solve the problem, but I'm not happy that Roku supplied a defective cable. I know of no way to contact Roku as they do not have a customer service support number or e-mail address. I feel Roku owes me a replacement HDMI cable.

Three months ago I purchased Roku Ultra connect to a 10 year old Sony 720P TV, using my own cable, so far I've not had any problems with it.
0 Kudos
atc98092
Level 16

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

Roku does have contact info for support, but you have to read through the self-help pages first. After you've gone through them, you get a phone number (not toll-free) and I think an email address. I've also heard they respond quickly on Facebook. I don't remember any of my Roku players ever including an HDMI cable. But if yours came that way, I'm certain they will replace it.
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Matt9876
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

I have had a very strange thing happen with HDCP purple screen problem 1.2 and 1.4 compatible on my Hisense 4K TV.

After purchasing a Samsung UHD 4K TV to fix my hit and miss purple screen problem with my Roku premiere plus in the living room and the Hisense 4K TV, I moved the Hisense 4K TV to a bedroom and connected it to a Roku 4 on HDMI port number 4 on the TV, (a never used port before , always connected to ports 1-3 )

Roku 4 offered full support of the 4K modes on the Hisense TV instead of just one.

I fixed it ,just don't understand how I fixed the purple screen problem and surely would not have paid for the new Samsung UHD TV if I had known it was that easy to make the Hisense 4K TV work.
ROKU Premiere Plus
ROKU 4
ROKU 3
Tablo OTA DVR
Samsung 4K UHD TV
Hisense 4K TV
0 Kudos
JDC
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

Solution for me and fix
Go to advance display settings and disable auto adjust display refreash rate and set HDR subsampling to 4.2.2
0 Kudos
viviwells
Level 7

Re: Roku Ultra - HDCP Unauthorized... AGAIN!

I tried the 4:22 thing and it did not work, but this procedure worked like a charm:

Do this procedure and you should not have a problem with HDCP Unauthorized again...good luck

Go to "Settings" and click ok
Go down to "System" and click "ok"
Go down to "Advanced System Settings" and click "ok"
Go down to "Advanced Display Settings" and click "ok"
On "Auto-adjust display refresh rate" click "ok"
Click "ok" to make sure the check mark is next to "Enabled"
0 Kudos