Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Roku TV 9.4.0 audio sync issues with EAC3

I have a 55" TCL Roku TV (55S405) and a TCL Alto 7+ soundbar (TS7010). Ever since 9.4.0, I've had issues with audio sync. The audio coming from my soundbar is delayed relative to the video.

At first, I figured out that one issue stemmed from the HDMI ARC handshake failing, which has been extensively reported as an issue with 9.4.0. It was defaulting to stereo, not even recognizing that the soundbar could play Dolby Digital.

Manually setting the HDMI audio mode to Dolby Digital fixed the sync issue with AC3. (DTS files seem okay, as well?) But there is still significant audio delay when direct playing EAC3 audio in mkv files. This wasn't an issue previously.

It seems like people on the Plex forums are all having similar issues: https://forums.plex.tv/t/latest-tcl-roku-tv-update-causing-plex-audio-sync-issues/653534/6

7 Replies
Level 7

Re: Roku TV 9.4.0 audio sync issues with EAC3

Also experiencing this issue and hope it gets addressed soon. Lots of available reference and test files at the Plex forum post referenced above but I'm also experiencing it in the Roku Media Player.

Level 9

Re: Roku TV 9.4.0 audio sync issues with EAC3

Ever since my Roku Express+ 3910 RW updated to software version 9.4.0 about a month ago, the audio is out of sync on several channels, including the Roku Channel and Amazon Prime Video, among others. Many others seem to have the same sync issue with other Roku devices, but there has been no response or fix from Roku. I'm using the device with a traditional TV via the composite AV input. Can you please help? 

Tags (1)
0 Kudos
Level 7

Re: Roku TV 9.4.0 audio sync issues with EAC3

I can confirm. This does not effect my Roku Ultra 2020, but does effect my Ultra 2019.

AC3 is delayed about 300ms relative to video. It was not an issue prior to 9.4.

I have tried this through my AV receiver (Onkyo TX-NR797), through a sound bar (Vizio SB3651) (HDMI-ARC), and direct to TV (Philips 4k). Problem exists in all configurations.

These files all stream perfectly to laptops, mobile devices, xbox, etc. And used to stream perfectly to the Ultra 19 prior to the 9.4 firmware update.

All video in MKV is h.264 or h.265 ranging from 720p to 4k.

All audio is either AC3 2.0 or 5.1, 128 kbit or 384 kbit respectively.

All Muxing is done through MKVMerge (MKVtoolnix). I tried to transcode a few files using FFMPEG to mux to MKV which lessened the delay but did not remove it

Streaming platform is Mezzmo. They have a roku app that exhibits this issue as well as accessing the Mezzmo server through Roku Media Player app exhibiting the same problem.

Also of note, Roku's "Audio/Volume Options" where you can select "Off", "Leveling", "Night" modes while streaming will become locked out from changes after trying to play a file until a reboot of the Roku.

I opened a trouble ticket with them last week.

AMA if I can help in any other way

Level 7

Re: Roku TV 9.4.0 audio sync issues with EAC3

Also experiencing the same issues on my TCL 75” Series6 TV with PLEX, no sound bar. As a test I setup a Servillo test server with DNLA using the same PC hardware and no issue using Roku Media Player. 

0 Kudos
Level 8

Re: Roku TV 9.4.0 audio sync issues with EAC3


@talex05 wrote:

I can confirm. This does not effect my Roku Ultra 2020, but does effect my Ultra 2019.

AC3 is delayed about 300ms relative to video. It was not an issue prior to 9.4.

I have tried this through my AV receiver (Onkyo TX-NR797), through a sound bar (Vizio SB3651) (HDMI-ARC), and direct to TV (Philips 4k). Problem exists in all configurations.

These files all stream perfectly to laptops, mobile devices, xbox, etc. And used to stream perfectly to the Ultra 19 prior to the 9.4 firmware update.

All video in MKV is h.264 or h.265 ranging from 720p to 4k.

All audio is either AC3 2.0 or 5.1, 128 kbit or 384 kbit respectively.

All Muxing is done through MKVMerge (MKVtoolnix). I tried to transcode a few files using FFMPEG to mux to MKV which lessened the delay but did not remove it

Streaming platform is Mezzmo. They have a roku app that exhibits this issue as well as accessing the Mezzmo server through Roku Media Player app exhibiting the same problem.

Also of note, Roku's "Audio/Volume Options" where you can select "Off", "Leveling", "Night" modes while streaming will become locked out from changes after trying to play a file until a reboot of the Roku.

I opened a trouble ticket with them last week.

AMA if I can help in any other way


 

0 Kudos
Level 8

Re: Roku TV 9.4.0 audio sync issues with EAC3

Also of note, Roku's "Audio/Volume Options" where you can select "Off", "Leveling", "Night" modes while streaming will become locked out from changes after trying to play a file until a reboot of the Roku


Regarding your point here, this was the thread I opened and a workaround below. Glad I'm not the only one with this issue.

https://community.roku.com/t5/Roku-Device-Features-Settings-Updates/Audio-Dropouts-On-4660X-Ultra-am...

 

0 Kudos
Level 8

Re: Roku TV 9.4.0 audio sync issues with EAC3

I'm getting audio sync issues with eAC3 and drop outs as well on the Plex app. Pretty ordinary stuff from Roku.

0 Kudos