Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Hogfan2502
Level 7

Roku Premier+ has to be rebooted every time I try to use it to get video.

My Roku Premier+ has been working fine since i've had the it, which is 3 years or so. Now all of the sudden the past few days I have to unplug my roku and plug it back in to get a picture/video on the screen. Works fine after that, but when I turn my tv off or switch to my xbox or ps4 and then switch back to my roku I get just a black screen, won't display anything. I again have to unplug it and plug it back in to get something on the screen besides a black screen. Very frustrating! 

I have my roku plugged up to a Denon receiver and a Samsung KS8000 TV. I've tried different HDMI cables, switched to another roku, etc, and they all do the same, have to unplug the roku and plug back in to get any video. I have an apple TV, xbox one x and ps4 hooked up to the same denon receiver and tv and those all work fine so it has to be a ROKU issue. I have also tried different hdmi ports and all do the same. 

2 Replies
AV-IT-Guy
Level 7

Re: Roku Premier+ has to be rebooted every time I try to use it to get video.

I am having a similar problem with my setup in my living room. Roku Ultra, RX-A880 & Vizio P65 (2018) Rebooting seems to clear it up, other sources (Xbox One X, UX-800P) are unaffected.
TAGINC
Level 7

Re: Roku Premier+ has to be rebooted every time I try to use it to get video.

I have the EXACT same problem. . .If I do the remote "reboot" (hit the "home" key 5X; the the "up" arrow one' the "fast forward" key twice and the "rewind" key twice the system will reboot and work fine.  It will do the same thing if I unplug the unit.

 

I have checked for updates. . .I even tried a complete "factory" reset by pushing the "reset" button. . .no avail.

 

Any help???

0 Kudos