Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
turtlejay
Level 9

Re: Roku!! Please fix audio sync issues!

Thank you for the detailed response, I appreciate the effort. Clearly this was all a misunderstanding.
0 Kudos
Tajson
Level 8

Re: Roku!! Please fix audio sync issues!

"turtlejay" wrote:
the only steps to reproduce are:

Those steps are so detailed that I will ask you to change the batteries in the remote.
Might still be a localized issue as in your network.
0 Kudos
turtlejay
Level 9

Re: Roku!! Please fix audio sync issues!

Wow, can you be more condescending? None of your replies have been productive. They've been rude and sarcastic. Go boost your posts in someone else's post.

The model of the ultra is 4660X2 and the firmware is 9.0 build 4142-46. I was just now able to get in front of a TV and look at the firmware.

The TV are all LGs one is a LM7600 I know for sure.
My mom's TV is a Samsung cant remember the model off hand.

The issue is not network related. There is no buffering issues or latency problems. I'm fully aware of my network and how its running. It doesn't matter if it's hbogo (Sesame Street for the kids), Plex, YouTube, Netflix etc. After a period of time(and before you ask I didn't put it to a stopwatch so it's probably random) I'll notice the audio and video are between a half and a full second apart. A reboot solves the issue but we end up in the same place eventually. Literally all that has to happen is watching something. There's no other way to say it.


I'm putting this here for reference if someone searches for similar and as I said before, I'm asking Roku to help me if they can and also others.
0 Kudos
Elijah_Baley
Level 8

Re: Roku!! Please fix audio sync issues!

Reading through this thread it is clear that some (at least one) people are having an issue with video/audio sync drifting of after a period of time and that those folks have seemed to have made a pretty good case for the problem being with their Roku Ultra.

However what has really been done is prove that the combination of that Roku and the local network and the remainder of the environment that has a problem.

It does seem that Rokus can be sensitive to minor problems in the local system, ex, I had a file the would play fine in Plex on most of my Rokus at all the possible locations throughout my house. However there was one location (bedroom) where that file and one other played at a low volume. I could place any of my Rokus there and the volume for only those files remained low. I could also take the Roku that was there and connect it at any other location and the volume was normal. All my Rokus are connected wired and connect directly to my TVs via HDMI.

I spent some time trying to find what could possibly be the cause but I had no luck.

I finally "fixed" the problem by reencoding the problem files from mkv to mp4 using Freemake. (For some reason I could not get handbrake to correctly fix the problem and produce a watchable file.)

From all my testing I have decided that Rokus are sometimes extra sensitive to the environment and, sometimes, one model can be sensitive while another is not in a given environment. (This comes from another different problem I have had where Roku Ultras worked correctly and Roku 3s did not at a given location)

Now to the problem. I "think" it is possible that the OPs problem could be his Roku but I do not think it is a general Roku problem because my, and several of my friend's, Rokus (both Ultras and Roku 3s) have no lipsync problems in any app used. (Netflix, Amazon, Fox Sports, Plex, Emby, NHL and several others)

I believe there is something in the OP's setup that is the cause of his problems (assuming it is not a problem in his Roku) but what that issue actually is I cannot even guess.

One more time: There cannot be a systemic sync problem in any of the Rokus causing sync issues or there would be a MUCH larger outcry about it and there would be at least a few of 30 or so Roku Ultras (and 80 or so Roku 3s) that I know about would show the problem. But the fact is that there is not one of those Rokus showing the problem. So it is something in the OPs setup that is causing the problem or that one Roku is defective.

I know that this post does not really provide ant help but I wanted to point out that it is nearly impossible for there to be any general problem in the Rokus involved that is causing the problem.

Edit: In the years I have had Rokus, since they were introduced (I had an original N1000 from back when it was called the "Netflix Player" ) and I have had at least one Roku from each generation, I have NEVER had Roku support "fix" anything or even be helpful in the process of fixing something. It has always been posters (regular users) here or elsewhere that have helped me resolve problems. In general Roku support is less that good.
Two Roku Ultras, three Roku 3s and a Roku 1
"Part of the secret of success in life is to eat what you like and let the food fight it out inside." Mark Twain
Van Roy's Law: An unbreakable toy is useful for breaking other toys.
0 Kudos
turtlejay
Level 9

Re: Roku!! Please fix audio sync issues!

I would settle for being able to downgrade to prior software because it worked fine before the last update. While I understand your point of view and assumption, there's is no viable reason for this other than a software issue. If it was hardware or network reboots wouldn't fix it. As another example, my son watches the same 10-15 videos on Sesame streets YouTube channel. They work perfectly fine. The devices with the latest software work fine too, for a little while. Then the audio acts up and we need to restart. I'm convinced it's a glitch in the firmware. Regardless if only a handful of people are experiencing it

I'm going to try the solution pointed out here:

https://forums.roku.com/viewtopic.php?f=28&t=143114

Hopefully it helps
0 Kudos
turtlejay
Level 9

Re: Roku!! Please fix audio sync issues!

0 Kudos
Community Manager
Community Manager

Re: Roku!! Please fix audio sync issues!

Thanks for continuing to share your observations here. 

If you're running into this type of issue, to test, you might try disabling any 'Volume modes' (on supported models) during playback of any content by pressing the * key, and using the lefthand menu to turn these off. 

Please PM me with the following info and I will follow up with you directly:

- Roku device serial number(s) from Settings>System>About 
- Specific channels (apps) and content examples that the issue occurs on
- Your TV make/model
- Do you use an A/V receiver with your TV? If so, what is the make & model? 
- When does the issue occur? After a specific period of time during playback, etc.?
- Do you have any volume mode settings enabled, such as 'Leveling' or 'Night'? Does turning these off clear up the issue? 

Cheers,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
iamkoza
Level 7

Re: Roku!! Please fix audio sync issues!

Ever since the 2-21 update having the exact same issues everyone here has commented on. Happening to me on yttv, Amazon, Hulu. Either audio is 2 seconds behind video or it's choppy and unlistenable. Menu system restart fixes it for a few hours. Glad it's not just me though. my streaming stick upstairs not having this issue



ultra 9.0.0, build 4142-46
roku set to output at 1080p
v: vizio m70d3, firmware 5.0.16.1 
avr hdmi out plugged in to hdmi-1
avr: denon x2200w 
wifi 2.4ghz, 
roku system test said good connection 47mbps
router: netgear nighthawk r6700

i did not change anything in my setup. i believe the vizio update went live in december, but i dont know when it was applied to my tv. i feel somewhat confident the only change was the roku software update applied on 2-21.

last night i tried the "fix" given here, have not been home today yet to see if it helped
https://forums.roku.com/viewtopic.php?f=28&t=143114
0 Kudos
maddscot
Level 7

Re: Roku!! Please fix audio sync issues!

I too was having this issue with my Sonos Soundbar with Roku Ultra in one room.   Thought it was the Sonos, but after trying to troubleshoot that with no results I reviewed sync issues with Roku.   Went through a few settings and changes but reverted back to my normal set up (nothing special, standard as is) and then pulled the power on the Roku to reset.   This seems to have solved my sync issues thus far.  Settings on Roku are Auto for audio as it came with first set up.   HDMI from TV to Roku only no amp, no other devices (streaming only for our home
0 Kudos
joeymas
Level 7

Re: Roku!! Please fix audio sync issues!

Turn off direct stream for both audio and video.
0 Kudos