Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
Bacon
Level 9

Roku, PLEASE fix this annoying UI bug

Jump to solution

This bug was introduced in one of the 8.0.1 build updates, and I was hoping it would be fixed in 8.1, but it's still in there on my Premiere+.

Anyway, the bug causes overlays in every single app to float up and to the left, so the video which causes the video to show at the bottom and right side of the screen where the overlay should be. I realizes it's partly an OCD thing, but it's been driving me nuts and looks very sloppy. And before anyone asks, this has nothing to do with my TV, HDMI, or the Roku hardware itself.

Here's some pics:

Youtube TV


Hulu


The Roku Channel

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
ok this is fixed with OS 9.2.0 build 4106-29.

After the update my Roku was only outputting 1080p with auto detect selected and I had to reset it to output 4K which was weird, so check on that...
0 Kudos
12 Replies
Emissary35
Level 7

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
Roku at it's best, creating bugs with every firmware update, you can always count on that.
0 Kudos
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
This bug is still present in OS9. It also isn’t limited to my 2016 Primere+, as my Streaming Stick+ exhibits the same problem.

I can’t be the only one noticing this...
0 Kudos

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
I guess I don't know what it is that I'm looking at/for. What is the issue?
0 Kudos
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
"scottypie1234" wrote:
I guess I don't know what it is that I'm looking at/for. What is the issue?

You see the thin line on the bottom/right of the screen? That's the video playing underneath the on screen display. The OSD isn't completely covering the screen since it's off center.
0 Kudos
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
Got a 9.0 build update the other night. This bug is still present.
0 Kudos
DBDukes
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
"Bacon" wrote:
Got a 9.0 build update the other night. This bug is still present.

You’re seeing it. Others aren’t. So, what’s the difference? Dunno. It’s time to dig. It may take some serious troubleshooting. Get rid of all pre-conceived notions, and try some thing. You know all that. You’ve been around a while and understand all that. So let’s see what we can figure out.

First, are you connected directly to the TV? Not through any other device for any reason? If through any other device for any reason, avoid and connect directly to the TV.

Next, does it happen on all TVs? Test on more than one TV. If you don’t have more than one TV, ask a friend if you can bring your Roku over to test.

Does it happen on every HDMI port on every TV?

Do any other devices exhibit the issue? Blu-Ray player, game system, anything that uses HDMI? If you have devices using HDMI that display fine, disconnect that device and plug 5he Roku app n to that HDMI cable. Did the issue remain?

What TV? Make and model.

Anything unusual at all, let us know. It’s not the software alone, or I’d have it along with everyone else. So something else has to be in the mix. Figuring that out will be a challenge.
DBDukes
http://www.dbdukes.com/
Roku Ultra (4660)
Roku Premiere+ (3921)
0 Kudos
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
"DBDukes" wrote:
"Bacon" wrote:
Got a 9.0 build update the other night. This bug is still present.

You’re seeing it. Others aren’t. So, what’s the difference? Dunno. It’s time to dig. It may take some serious troubleshooting. Get rid of all pre-conceived notions, and try some thing. You know all that. You’ve been around a while and understand all that. So let’s see what we can figure out.

First, are you connected directly to the TV? Not through any other device for any reason? If through any other device for any reason, avoid and connect directly to the TV.

Next, does it happen on all TVs? Test on more than one TV. If you don’t have more than one TV, ask a friend if you can bring your Roku over to test.

Does it happen on every HDMI port on every TV?

Do any other devices exhibit the issue? Blu-Ray player, game system, anything that uses HDMI? If you have devices using HDMI that display fine, disconnect that device and plug 5he Roku app n to that HDMI cable. Did the issue remain?

What TV? Make and model.

Anything unusual at all, let us know. It’s not the software alone, or I’d have it along with everyone else. So something else has to be in the mix. Figuring that out will be a challenge.

Issue is only on Roku devices. It's on any TV that has 1:1 pixel mapping regardless of HDMI port. TV in the pictures is a LG OLED C7 hooked up directly (I only have 4k TVs for testing).

My guess is if you have a 4k TV and aren't seeing it, you either aren't using a 1:1 pixel mode, or have a pixel orbiter enabled which slights shifts the screen around to where it won't be noticeable 100% of the time.
0 Kudos
Bacon
Level 9

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
Bug is still present on OS 9 build 4142-29.

I have figured out that it only happens when Rokus are set to 4K. When set to 1080p UI overlays are properly aligned.
0 Kudos
Tajson
Level 7

Re: Roku, PLEASE fix this annoying UI bug

Jump to solution
"Bacon" wrote:
I have figured out that it only happens when Rokus are set to 4K. When set to 1080p UI overlays are properly aligned.

The overlaying UI will try to "predict" by the source video dimension and have "funny" results like that. Most likely, the source is not a true wide screen format and something is trying to adjust.
0 Kudos