Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ThePossum
Level 7

Roku OS version 10 on my Express made watching Netflix a miserable experience

I have a Roku Express purchased in 2018, I'm not 100% certain as to which particular model number it is.

Recently, the OS automatically updated to version 10.0.0, which was the precise moment my new issues began. I first noticed it when, basically, nearly EVERY time I launch a new app, that it needs to re-download the app from the internet again. Usually I stick to "YouTube" "Crave" and "Netflix", and pre-version-10 they'd already be ready to go regardless. But now it just adds a delay nearly every time I am switching to something other app.

But that's just on the "annoying" side, not on the "problem" side. The problem I'm having is specific to Netflix.

In my troubleshooting, I've made sure that I've got my Netflix video set to a lower quality (I've had that set to SD via the netflix website for years now, the video quality was always fine). And I've even resorted to making sure the Roku is only talking to my tv with 720p HDMI, just to guarantee a lower resolution (and the associated bandwidth savings).

The specific issue I'm having is, basically EVERY time I'm watching any video stream through Netflix, after a random number of minutes there's a bit of a pause in the streaming where it gets a bit choppy; the remote's pause button is ignored for many seconds; I cannot even press the "Back" or "Home" button and get a response.

If I'm patient and I'm lucky, "usually" the Roku starts responding again. If I go back to "Home" I can restart the stream from roughly where I'd left off, and it will continue (until a random number of minutes and it chokes again).

If I'm NOT lucky, the Roku shows me a screen telling me that my HDMI is incompatible or somesuch; but pressing Home and relaunching Netflix here, it all continues just fine. (Well, as I've indicated, "sort of" fine.)

And if I'm especially not lucky, the Roku will just up and spontaneously reboot.

I note that NONE of these issues happen with any other streaming services. JUST Netflix.

It's not a bandwidth issue, the other apps (ie. Crave) are just as bandwidth-intensive as Netflix. My gut feeling is that it's "just" the Netflix app using up all of the CPU.

 

PS. For what it's worth, my "Express" purchase was because my original Roku device (one that used RCA cables) was made defunct because Netflix, for example, stopped supporting it. I reeeeeally hope this isn't a case of history repeating itself.

0 Kudos
4 REPLIES 4\
StreamerUser
Level 20

Re: Roku OS version 10 on my Express made watching Netflix a miserable experience

Try the following:

1) To check your model # and firmware version:  Settings/System/About

2) To check for updates:  Settings/System/System updates/Check now

3) a) Remove NetFlix, b) RESTART THE ROKU (Settings/System/System restart/restart) <Must do this here!, c) Re-install NetFlix

0 Kudos
renojim
Community Streaming Expert

Re: Roku OS version 10 on my Express made watching Netflix a miserable experience

If what @StreamerUser suggests doesn't work, try the "clear the cache" routine:

On your Roku remote, press Home 5 times followed by Up once, Rewind (<<) twice, and Fast Forward (>>) twice.  If you do it correctly your Roku will reboot on its own.

Please respond back with what worked or didn't work.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Mtootill2
Level 7

Re: Roku OS version 10 on my Express made watching Netflix a miserable experience

We’re having the same issues with the delay or glitch when using Netflix or YouTube. Our device updated yesterday and we’ve tried all the suggestions in this feed and nothing is working. Maybe an update soon to fix this?

0 Kudos
ThePossum
Level 7

Re: Roku OS version 10 on my Express made watching Netflix a miserable experience

So before the weekend, I'd further reduced the video quality for my Netflix account, just to reeeeeally make sure that my bandwidth wasn't contributing to the issue. And then I followed your advice: deleted Netflix; rebooted; installed Netflix.

I didn't (yet) suffer any of the issues -- zero unwarranted dropouts and app crashes.

I've now re-updated my streaming settings to what I'd had before (the "0.7" instead of "0.3", as the HD quality is fairly much wasted on me, plus the lower bitrate lets other housemates get more bandwidth too, so there's that).

I'm going to consider this "solved" for me, so long as (hopefully) I don't have to push my video bandwidth back down. It's not thaaaat much of a difference between "low" and "very low", but occasionally some things that require reading (ie. embedded subtitles) will be more blurry. But if the issue returns I will come back here to update.

And an aside: For users having same/similar trouble with YouTube TV? DO NOT delete your YouTube TV app, at least in the short term. Google and Roku are currently at odds, and if you remove YouTube then you currently cannot reinstall. Hopefully they'll resolve their quarrel soon.

0 Kudos