Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dpengel3
Level 8

Roku Media Player started messing up DLNA stream

I have a collection of videos on a DLNA server, which the Roku Media Player channel can browse and play. I have a Roku 3. I've been using this arrangement to watch videos and movies from my DLNA server for over a year, with no problems.

Suddenly, my Roku 3 started playing the videos back in a weird (completely unwatchable) way. The audio sounds like scratch static, and the video looks like it's jumping multiple frames at a time, like a choppy sort of fast-forward. Difficult to describe completely.

Well, I had another Roku 3 sitting around, that I hadn't used in a while. So I plugged it in, hooked it to the network, did all the system updates and added the Roku Media Player channel. I browsed to the DLNA server, picked videos and watched them.

OK, so the first Roku 3 must have just gone bad, somehow, right? (By the way, other services like Amazon and the Roku channel have all continued to work fine, throughout.)

For about two weeks all was good again.

Then, tonight, the replacement Roku 3 started doing the same thing. Amazon, etc. streams fine. My DLNA doesn't. So I went and got another Roku device that I have (not sure of the model, not important to this question), plugged it in, browsed to the DLNA server, and I'm watching my shows, no problem. I did not restart or change the DLNA server--just replaced the Roku and things are running fine again.

But what's with the playback on the Roku 3? With two of them doing the same thing so close together, I don't buy that they're just "breaking". Also, since the second Roku 3 worked fine for a couple of weeks AFTER making sure all the software was up to date, I don't believe it's just the latest Roku Media Player app.

Has anyone else run into something like this?

0 Kudos
4 REPLIES 4\
gk802
Level 10

Re: Roku Media Player started messing up DLNA stream

See the topic "Roku OS 10.0 Update Breaks Surround Sound" under "Roku Device Features, Settings & Updates".  The discussion there may describe the same issue as you're experiencing.

0 Kudos
dpengel3
Level 8

Re: Roku Media Player started messing up DLNA stream

Thank you, @gk802. It sure looks like the same issue - except for the bit about updating everything, seeing the streaming working for a couple of weeks (this is after it broke on the "first" Roku 3) and then it braking again. I have to question why the update didn't break the second Roku 3 right away.

I checked the settings - it is set to Auto Detect.

I am going to hold off marking your comment as the answer until a fix comes out that I'm able to try and verify. (Right now I'm exploring the possibility of using secret screens to downgrade the Roku 3.)

0 Kudos
PathfinderTech
Level 7

Re: Roku Media Player started messing up DLNA stream

I have started having the same issue and have been playing these videos for inner a year. They are kids videos and my daughter watches the same videos after school several times a week. No sound issues playing on my Roku tv or chromecast.

0 Kudos
Gsus
Level 7

Re: Roku Media Player started messing up DLNA stream

I have the same problem, every playback video with surround sound is broken in my roku.

I will try to downgrade the firmware y and block undates in my roku. I belived that the updates on my roku was "stable"

0 Kudos