Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

ROKU BLACK DISPLAY

Jump to solution

Good night I have a problem, when I am playing a movie or some program the image goes away and returns when he wants, I turn it off, I disconnect it and still he continues with the problem

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Roku Employee
Roku Employee

Re: ROKU BLACK DISPLAY

Jump to solution

@josemsms 

Thanks for the inquiry. 

Have you tried replacing the HDMI cable that you are using to connect the device to your TV as well as trying another HDMI port on your TV?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
7 Replies
Highlighted
Roku Employee
Roku Employee

Re: ROKU BLACK DISPLAY

Jump to solution

@josemsms 

Thanks for the inquiry. 

Have you tried replacing the HDMI cable that you are using to connect the device to your TV as well as trying another HDMI port on your TV?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
Highlighted
Level 7

Re: ROKU BLACK DISPLAY

Jump to solution

Thanks you I'm change the cable and the problem is solvet

0 Kudos
Highlighted
Level 7

Re: ROKU BLACK DISPLAY

Jump to solution

I have a black display problem too, but I don’t think it’s an HDMI cable issue.

I have a 3710X Roku Express+,  software version 9.2.0 build 4804-28. Beginning not later than March 14 when I first noticed the problem, and not earlier than March 10 when all was fine, I get a black screen for all video content on all my channels (Netflix, Amazon Prime, Hulu, Comedy Central, Roku Channel, ...)

Understand, ONLY video doesn’t work. Audio plays fine. Subtitles also play just fine. Static images during menu/channel/program selection display fine, as does video during the 30 seconds or so of Netflix previews. But once any program begins, video goes black.

Given these symptoms, I don’t believe this would be a bad HDMI cable. The cable worked fine for well over a year, during which no one touched it. I have NEVER heard of a cable just going bad from regular use. I’ve also unplugged/reconnected both ends, no change. I have not tried a full reset of the box.

It’s also not some sort of funkiness in the TV, since the satellite TV on HDMI 1 (Roku is on HDMI 2) works fine.

I appreciate any guidance. Thanks in advance 

Marcel

0 Kudos
Highlighted
Level 7

Re: ROKU BLACK DISPLAY

Jump to solution

I’m also having black screen picture only issues. Volume works fine, menu to pick out what to watch works. But as soon as I hit play it’s black, even if I hit forward it shows at bottom of screen. I’ve tried many different apps & called internet company. Only thing thing I can do because it’s a Netflix TV is watch that. I have a Roku express.

0 Kudos
Highlighted
Level 7

Constantly having to unplug the power cord of the streaming stick + due to No signal message

Jump to solution

It seems almost everytime I turn on my TV I no longer see the Roku home screen but the no signal message.  I am able to get the Roku home screen to pop up after I unplug the power cord to my RokuStreamingStick+  > I have a new Sony Bravia XBR-49x800 series TV and has worked well since I bought it in December.  

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: ROKU BLACK DISPLAY

Jump to solution

@Muhal @josemsms 

Thanks for the note.

For troubleshooting purposes, have you tried replacing the HDMI cable that you are using to connect the device to your TV as well as trying another HDMI port on your TV?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Constantly having to unplug the power cord of the streaming stick + due to No signal message

Jump to solution

@kschwi62 

Thanks for the note.

Have you tried using another HDMI port on your TV to see if that resolves your issue?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos