Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
johnny121b
Level 7

ROKU 4 (4400X) stuck in reboot loop

The title pretty much sums it up.  I have a ROKU 4, which continually starts up, displays the dancing "ROKU" screen for a moment and eventually restarts.  I've left it looping like this overnight without improvement.  I connected the unit directly to my network switch (30mb cable internet)- hoping it would pull an update....no change.  It normally utilized a 5GHz AP.  All my other Roku's (Roku 3s) are okay, and this one had a relatively sheltered life- always protected by a UPS.  I put another Roku 4 in its place (keeping the same p/s AND HDMI cable- to prove a point), but I'm rather annoyed this unit simply woke up Thursday and decided it wasn't going to work again.

Is there nothing that can be done to flush whatever poison pill firmware/glitch has it stuck in Groundhog Day?  I'm wishing the effort that went into the cutesy, toe-tapping ROKU logo, had instead been spent on some sort of watchdog timer or non-volatile bootloader. 
0 Kudos
3 Replies
jeffrok
Level 11

Re: ROKU 4 (4400X) stuck in reboot loop

Did you try a hardware factory reset? That's probably your last hope.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
johnny121b
Level 7

Re: ROKU 4 (4400X) stuck in reboot loop

If you're talking about holding down the RESET button on the bottom and cycling power to the unit, yes.  
0 Kudos
atc98092
Level 13

Re: ROKU 4 (4400X) stuck in reboot loop

"johnny121b" wrote:
If you're talking about holding down the RESET button on the bottom and cycling power to the unit, yes.  

I believe to do a true hard reset, you must hold the button for a minimum of 30 seconds. Otherwise it is a soft reset and doesn't accomplish the same thing.
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos