Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

I also have a Roku Ultra. When I first bought the device last year I had this problem where the sound would drop in and out. I upgraded my HDMI cord, as some posters suggested, but no luck. Eventually there was an update that fixed the problem and I didn't have it for a long time...until a few weeks ago. Now, suddenly, the problem is back and no setting I choose will fix it. Please, Roku, either let us go back to a previous version, or FIX THIS.
0 Kudos
Highlighted
Level 9

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

 Please check for a firmware update for the 4640.
0 Kudos
Highlighted
Level 7

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

No update available yet Dale. I will keep checking and post back with the results. Thank you for the reply!
0 Kudos
Highlighted
Level 7

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

Dale, I am happy to report that I downloaded the update this afternoon and I have 5.1 sound again. I checked a variety of channels to verify. Thank you and the team very much for fixing this issue!
0 Kudos
Highlighted
Level 8

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

After receiving the update, Dolby 5.1 over HDMI is now working for me again, too.  The sleep bug I was experiencing in my setup was also fixed.

I noticed that menu sounds are still being silenced over optical once the DD decoder has been engaged.  Like I said previously, not that big of a deal to me, and I avoid it anyways as I prefer utilizing the HDMI audio feed.
0 Kudos
Highlighted
Level 7

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

I also just pulled down an update for my Roku Ultra (2016) and am happy to say 5.1 is back for my Netflix and Plex!  Thanks!!!

PS - I’m using HDMI
0 Kudos
Highlighted
Level 7

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

Same here. Working fine again - I hope they continue to support Dolby D on the 4640
0 Kudos
Highlighted
Level 7

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

Hi, I'm afraid the the latest update has *caused* this problem for me. I think I've read this thread carefully so that I'm not missing something obvious.
I have a Roku Ultra 4640X, with optical audio out going to an Onkyo receiver that doesn't have HDMI in, so that's not an option. As of the latest update, 8.1.0 build 4145.29 that I received a couple days ago, any Dolby Digital output does not work. I still have UI sounds, and stereo music plays, and if I force the audio settings to PCM Stereo it works. But setting the audio to DD like I always have just stopped working. It was working fine for the previous month, even after getting the build that was problematic for others on this thread. I have tried rebooting.

Any others with this problem lingering? Thanks.
0 Kudos
Highlighted
Level 12

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

"Kakkab" wrote:
Hi, I'm afraid the the latest update has *caused* this problem for me. I think I've read this thread carefully so that I'm not missing something obvious.
I have a Roku Ultra 4640X, with optical audio out going to an Onkyo receiver that doesn't have HDMI in, so that's not an option. As of the latest update, 8.1.0 build 4145.29 that I received a couple days ago, any Dolby Digital output does not work. I still have UI sounds, and stereo music plays, and if I force the audio settings to PCM Stereo it works. But setting the audio to DD like I always have just stopped working. It was working fine for the previous month, even after getting the build that was problematic for others on this thread. I have tried rebooting.

Any others with this problem lingering? Thanks.

Can others who had this issue and now fixed confirm they have the same firmware version as you  do now?
0 Kudos
Highlighted
Level 8

Re: No more 5.1 Sound -Ultra Stopped Supporting Dolby D

"Heyitsrick" wrote:
"Kakkab" wrote:
Hi, I'm afraid the the latest update has *caused* this problem for me. I think I've read this thread carefully so that I'm not missing something obvious.
I have a Roku Ultra 4640X, with optical audio out going to an Onkyo receiver that doesn't have HDMI in, so that's not an option. As of the latest update, 8.1.0 build 4145.29 that I received a couple days ago, any Dolby Digital output does not work. I still have UI sounds, and stereo music plays, and if I force the audio settings to PCM Stereo it works. But setting the audio to DD like I always have just stopped working. It was working fine for the previous month, even after getting the build that was problematic for others on this thread. I have tried rebooting.

Any others with this problem lingering? Thanks.

Can others who had this issue and now fixed confirm they have the same firmware version as you  do now?

I've been using the HDMI audio output recently, but I just switched back to optical output and am still getting DD 5.1.  I'm on 8.1.0 build 4145-29.  Interestingly, in my setup, the UI sounds are silenced after engaging the DD decoder (sort of the opposite condition), but I still get DD 5.1 when playing content.
I would try things like unplugging/rebooting the Roku (and maybe other connected AV devices), verifying inputs are set correctly and remove/reconnect cables (if you're getting some sound probably not an issue) if you haven't already done so.  If none of this accomplishes anything, it's possible there's a bug that affects your specific AV setup.
0 Kudos